I've created a DataView web part and feed it with data from a public RSS feed using server-side script as a data source. Everything works great in Sharepoint Designer but in the browser I get the following error.

Unable to display this Web Part. To troubleshoot the problem, open this
Web page in a Windows SharePoint Services-compatible HTML editor such as
FrontPage. If the problem persists, contact your Web server

I'm doing it this way is because I would like to use the <description /> part of the rss item as the title in my web-part. This because the real title is the description without spaces (from a MOSS page list)

I've tried to remove all xsl in the web part except <xsl:copy-of select="*"/> and all data is displayed in Sharepoint Designer but still the same error in the browser.

I've googled all day and the only thing I found was something about maybe some authentication problem. But the feed is public?

Is there a way for me to get more information from this error? Maybe from some log-files somewhere? I checked the 12-hive\logs but my 12-hive name is 60 and it doesn't contain any logs? Maybe it's because it's an old Sharepoint Portal Server. I found some logs in C:\Program Files\SharePoint Portal Server\Logs but they didn't contain any information about the error?

Oh, I found one more thing. Most common error was if you reset your site and the list IDs gets broken in webpart. I'm creating a new webpart and it's not this error since I use RSS.

Please, can someone help me?

The rss-feed (Swedish) can be found at:


Just to be clear. The RSS feed is located at a public MOSS. The receiving page is an old non public Sharepoint Portal Server.

1 Answer 1


Finally, I found out how to solve this. I tried fetching data from other RSS feeds which worked fine. And I could access my RSS-feed anonymously so I figured out that it had to be something in the web part.

I use parameters in my call to get the feed and there was a setting in the "Data Source Properties" called "Runtime Parameter?". I unchecked that and then it worked just fine. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.