1

We have a SharePoint Server 2013 search dedicated farm and we're indexing multiple contents such as SharePoint sites and Documentum.

For each content type, we've created a specific result source that targets a specific URL.

In preproduction environment, when we type "*" in the search bar, all indexed content is returned, but in the production environment, only 6 elements are returned.

We've tried to index production content on the preproduction farm and all content has been returned on the search page. In both environments, content indexing is working fine.

What could be the reason that makes production results only show 6 elements on production environment but all the results on preproduction environment?

Thanks.

  • Is the security for the account performing the query different in Production than in Test? – Matthew McDermott Aug 22 '18 at 21:01
0

Run the full crawl once, and ensure there are no errors. Check and fix for any error specific to that particular URL and ensure that there is none.

  • Full crawl has been executed successfully, there are more than 200000 success and less than 1000 errors. These results are the same between preproduction and production env. – KhalilG Aug 21 '18 at 8:07
  • Any search result webpart configuration you're missing? – Satyajit Paul Aug 21 '18 at 8:55
  • No, webparts have been configured the same way. – KhalilG Aug 21 '18 at 10:18
0

You can check crawl log to find how many items are crawled.

Did you set query string in your search result web part of your search result page? You can go to search result page and edit it, then edit the search result web part, click "Change query", then make sure query source is "Local SharePoint Results(System)", and there is no string in Query text, like the below. enter image description here

Except the above, you also need to make sure the account that you use to search has permissions on all items. If the account doesn't have permissions on an item, he/she will not see the item in search result.

  • Hi Kally_MSFT, web parts have been configured the same way in both environments, and crawls logs show the same number of items (success, warning and failure). – KhalilG Aug 22 '18 at 9:50
  • what permissions does the account have when searching in pro environment? you can try to use search content access account to search, compare the result – Kally_MSFT Aug 23 '18 at 1:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.