3

Selective sharepoint List templates are not listing as Apps that can be used (Add an App). Any clues as to why this is so?

I am able to save other lists as templates and these do show up as available Apps. This particular list was created from SP2010 (we are now SP2013), and appears to have been created from a Task type list.

Update:

I have tried to update the TemplateID and the FeatureID in the stp file as per this site

https://social.technet.microsoft.com/Forums/en-US/20bda23e-ec92-47d0-a632-6c031b61c79a/list-template-not-visible?forum=sharepointgeneral

However, this did not work.

1

You can try browsing to the list template gallery to inspect the stp template

https://<site>/_catalogs/lt/Forms/AllItems.aspx.

You will need to confirm that there is a checked in major version.

For task lists you would also need to check that the feature Team Collaboration Lists Feature is activated

  • Team Collaboration Lists is activated. Under the lt folder, there is no Forms folder, just the straight stp files. I cannot checkin the site: Checkin has been turned off - Require content approval for submitted items? is set to No. – southskies Aug 21 '18 at 5:41
  • As stupid as it sounds may I please confirm that you are in fact trying to deploy the app in the same site as the list template gallery – James Randal Aug 21 '18 at 7:27
  • All stupid questions welcome ;) Yes, the deploy is back to the same site. There are multiple lists on this site, I can save these as templates and create new lists from these, but there are three in this situation where the template is created, they are in the right locations, but they are just not available for creation of a new app. – southskies Aug 21 '18 at 7:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.