Error: The secure sockets layer (SSL) certificate sent by the server was invalid and this item will not be crawled.

  1. I confirmed "Ignore SSL warnings" is set to yes.
  2. The SSL certificate in IIS "Server Certificates" expires in 2019.

How would I fix this error?

  • What happens when you browse to the site AS the Crawl Account FROM the Crawl Server? Aug 20, 2018 at 21:02
  • The web site loads and I can browse pages.
    – C1TonyB
    Aug 21, 2018 at 17:48

2 Answers 2


According to your description, you have selected Ignore SSL certificate name warnings, but the error still occurs.

For this issue, please try clearing the configuration cache and doing an IISRESET, then check if the issue is resolved.

Information about Clearing SharePoint configuration cache, you could refer to the following article.


  • Clearing the cache and resetting IIS did not resolve this issue.
    – C1TonyB
    Aug 21, 2018 at 18:24
  • I created a new web application on port 80, added some content to a new site collection and successfully crawled this site. However, the error message changed from the SSL error to: Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled. I verified default content access account has full read to the web application,
    – C1TonyB
    Aug 27, 2018 at 13:44
  • can retrieve people is checked (user profile service) and is a full control admin for search service application. Any thoughts on new error message?
    – C1TonyB
    Aug 27, 2018 at 13:46

My fix/workaround is: I extended the https site to http, turned off crawl on https and crawled the http site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.