2

We are supporting SharePoint 2013 live environment, with distributed cache service instance is running fine,

Suddenly received the Event viewer with cache cluster is down and restart it.

I restarted the cache cluster and received the error message with timeout error in starting the app fabric cache service.

I did remove-spdistributedcacheserviceinstance and later tried

add-spdistributedcacheserviceinstance.

Receiving the below error --

Add-SPDistributedCacheServiceInstance : ErrorCode:SubStatus:TCP port 22233 is already in use.

i checked port status using net-stat -a -b and the port 22233 status is showing established with distributedcacheservice.exe

How can i resolve this issue. Please help.

I am bit worrying as the incorrect distributed cache configuration may cause farm configuration database corruption,

1

I would start this way, Run the below command:

Get-SPServiceInstance | ? {($_.service.tostring()) -eq "SPDistributedCacheService Name=AppFabricCachingService"} | select Server, Status

Check how many servers return and whats their status? Is is required servers already in the list and status is up. Run this

Use-CacheCluster
Get-CacheHost

If status of all servers are up, then i think you are fine. Otherwise

Run Remove-SPDistributedCacheServiceInstance server complaining. Now wait once the Server compeltely removed from the cluster. Run this Add-SPDistributedCacheServiceInstance

  • I tried Remove-SPDistributedCacheServiceInstance and then Add-SPDistributedCacheServiceInstance but again getting the error message 'Port 22233' is already in use. I removed the distributed cache instance again and checked ports status using netstat command and could see port 22233 with status established and using distributedcacheservice.exe. I checked the same in Test environment with remove-spdistributedcacheserviceinstance and port 22233 is not showing in netstat list. will reboot the server solve this port releasing issue. – kumar Aug 18 '18 at 8:03
  • After running remove commmand,run the get-spservicesinstajce command and what's the output? – Waqas Sarwar MVP Aug 18 '18 at 11:52
  • the output of get-spserviceinstance is blank and the distributed cache service instance is deleted and i checked it in manage services in central admin. I checked the port 22233 status and it is still showing listening associated with distributedcacheservice.exe in netstat output. – kumar Aug 18 '18 at 15:13
  • i opened task manager and could still see distributedcache.exe running after ran remove-spdistributedcacheserviceinstance. Can i end the process in task manager or it should not be? – kumar Aug 18 '18 at 15:38
  • Try this script $instanceName =”SPDistributedCacheService Name=AppFabricCachingService” $serviceInstance = Get-SPServiceInstance | ? {($_.service.tostring()) -eq $instanceName -and ($_.server.name) -eq $env:computername} $s.delete() – Waqas Sarwar MVP Aug 18 '18 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.