0

I'm facing below exception when click on Reset Index in SharePoint 2013.

Do i need MS Office on the server?

Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (7d31ef95-a524-4ea3-abe9-d469e834e044).

Reason: Retrieving the COM class factory for component with CLSID {0FF1CE15-0005-0000-0000-000000000000} failed due to the following error: 80070005 Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).

Technical Support Details: System.UnauthorizedAccessException: Retrieving the COM class factory for component with CLSID {0FF1CE15-0005-0000-0000-000000000000} failed due to the following error: 80070005 Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)). at Microsoft.Office.Server.Search.Administration.Gatherer.get_AdminObject() at Microsoft.Office.Server.Search.Administration.Gatherer.ProvisionGlobalProperties() at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize() at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

Please provide any help to resolve this issue.

0

The account your are logged in probably doesn't have enough permissions. They might have been removed by mistake. I would do following:

  1. Login with farmadmin account and try to reset the index.
  2. If that fails run PSConfig, it will ensure permissions are correctly set.
  3. If you still facing the isssue run Process Monitor from sysInternals set the filter on outcome contains 'Denied' that should point you what registry\resource is being accessed and doesn't have enough rights.
  • I'm using farmadmin account. i don't know how to run psconfing. Please provide any steps to run it. – Chandhu Vutukuru Aug 17 '18 at 14:12
  • PSConfig is Sharepoint Configuration Wizard – Marek Sarad Aug 17 '18 at 14:59
0

When we try to reset our Index we do not get an error like yours but we run into a timeout every single time. The folloing steps allow us to do the reset. Maybe it helps in your case as well?

  1. Stop and Disable the Windows SharePoint Services Timer service (Found in Windows Services) on all servers in your farm.
  2. Stop and disable all crawls.
  3. Navigate to the cache folder on your WFE servers - Drive:\ProgramData\Microsoft\SharePoint\Config
  4. Locate the folder that has the file “Cache.ini”
  5. Back up the Cache.ini file.
  6. Delete all the XML configuration files in the GUID folder. Note When you empty the configuration cache in the GUID folder, make sure that you do not delete the GUID folder and the Cache.ini file that is located in the GUID folder.
  7. Edit the Cache.ini file.
  8. Select the entire contents of the Cache.ini file and delete it, replacing all the text with the number ’1′. Save the file and close it
  9. Start the Windows SharePoint Services Timer service on all four servers
  10. Note The file system cache is re-created after you perform this procedure.
  11. Make sure that the Cache.ini file in the GUID folder now contains its previous value. For example, make sure that the value of the Cache.ini file is not 1.
  12. Now perform an Index reset. Disable email alerts when asked.
  13. Perform a Full Crawl of your content sources
  14. re-enable the email alerts.

Credit does not go to me for this procedure but: http://jcaspadmin.blogspot.de/2014/05/sharepoint-2013-content-index-reset.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.