1

I'm mostly working on Sharepoint 'frontend' - never on the admin part of updates ect, so please bear with me. I have a new client that have SharePoint 2016 (on-prem) installed, running on a SQL 2014 - all on one server. Their SharePoint site has never been updated since the installation. :-( From what I could see, the windows updates have been running and installed until this morning (9 Aug 2018), but no other updates than those that came with Windows. I don't know if SP updates also come through windows, but their SharePoint give funny errors like when opening a sub site settings - it says 'File not found'. I had a look in the Central Admin and saw some updates did not run. See attached image.Screenshot

So I was thinking of doing an update to the latest version, hopefully this will fix the problems.

I have a few questions and need some guidelines please: 1. Whereto do I go from here regarding updates - do I need to install all updates one by one since the last update, or can I only update the latest one. 2. How do I run the updates, should I download them and if so, is there a step by step guide which I can use?

I would really like to help this client get the SharePoint fixed, but need help.

2
  1. You need to install latest cu, it will contains all previous updates.
  2. You have to download it from MSFT site, their will be 2 files (one start with sts n 2nd with wss)
  3. You need to install both files on all sharepoint servers in farm
  4. Now you have to run configuration wizard on all servers one by one.
  5. Test the sharepoint

Here you can get info about latest cu.August 2017 CU for SharePoint Server 2016 is available for download

One thing I recommend, always test the cu in lower farm n then proceed with production.also this activity will cause interruption so you have to do it in schedule manners.

  • Thank you Waqas - that answer my questions. If I install the files - do I just run them from their location? Do I need to stop some services like User Profile sync (think I saw something like that during my readings)? – Heste Aug 9 '18 at 13:31
  • If you have Search services configured, then make sure no crawl is running (best practices unscheduled the crawls until updates down). if you have User Profile Service Sync configured then make sure UPA sync stopped as well. – Waqas Sarwar MVP Aug 9 '18 at 13:45
  • 2
    You should just run Suspend-SPEnterpriseSearchServiceApplication. That will prevent any crawls from taking place. Run Resume-SPEnterpriseSearchServiceApplication when all servers have been upgraded via the Config Wizard. Also, the current patch level is the July 2018 PU, not Aug 2017 :) But I'd recommend waiting for the August 2018 PU which will be out on 8/14. – Trevor Seward Aug 9 '18 at 14:50
  • Thank you all. Fingers crossed I get all up and running again :-) – Heste Aug 9 '18 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.