I have installed PnP Powershell and I tried to run Connect-PnPOnline, but I got the following error:

Connect-PnPOnline : The 'Connect-PnPOnline' command was found in the module 'SharePointPnPPowerShell2013', but the module could not be loaded. For more information, run 'Import-Module SharePointPnPPowerShell2013'.
At line:1 char:1
+ Connect-PnPOnline -Url "https://test.rod.com/sites/Projects"
+ ~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (Connect-PnPOnline:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CouldNotAutoloadMatchingModule

So, I run "Import-Module SharePointPnPPowerShell2013" as the error suggests, then I get another error:

Import-Module : The specified module 'SharePointPnPPowerShell2013' was not loaded because no valid module file was found in any module directory.
At line:1 char:1
+ Import-Module SharePointPnPPowerShell2013
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ResourceUnavailable: (SharePointPnPPowerShell2013:String) [Import-Module], FileNotFoundException
    + FullyQualifiedErrorId : Modules_ModuleNotFound,Microsoft.PowerShell.Commands.ImportModuleCommand

I followed the instructions as stated in github repo, but still did not help.

1 Answer 1


Have a look at this github post. It worked for him.

He installed the SharePoint 2013 Client SDK and apparently it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.