1

Update:

Resolved (hope so). Maybe this is a bug and upgrade VS2017 to to 15.7.6 helps. I close my Chrome every time before f5

--

Every How-to for beginners in the net say "Hit F5 and voila!" - but my VS2017 hangs at this step. The only thing I can do - is close to Visual Studio.

Sometimes it works: I successfully deployed my provider hosted app twice today:

  • Disabled all chrome extensions and closed chrome
  • Tried to enable/disable Javascript Debugging in VS settings:

  • Played with firewall
  • Tried to stop/start IIS sites
  • Tried to set up my Add-in as "Startup project" in VS project settings..

But sometimes it works and sometimes not, I cannot find dependency.. Think it works if I restart pc, close all tabs in Chrome, close chrome, open VS first time, and hit f5 (not sure). But if I press Shift+f5 and then try debug again - it hangs

How do You debug Provider-Hosted Add-ins?....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.