2

We have a farm that sits behind a Forefront UAG server doing SSL termination. Traffic from the farm is un-encrypted over port 80 to the UAG server. The UAG server then sends the traffic encrypted over port 443 to the client. The SSL certificate sits on the UAG server and not on the SharePoint farm.

When users are logged in through the UAG server and they change the scope in the search to "This Site", the parameter "u=https%3a%2f%2fportal.foo.com" gets passed into the query string. The results page returns with no results. Manually changing the parameter from "https" to "http" causes the expected results to return. Search works fine with other scopes through UAG.

I thought about doing URL rewrites as an option, but would prefer not to. What is the best way to correct this?

2

Add the HTTPS version of the URL to the Alternate Access Maps in Central Administration. Even though it isn't actually reaching SharePoint with HTTPS, search needs to know that having HTTPS in the URL is valid for that content.

  • Very simple! That solved it. – CCCPSpy Dec 5 '11 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.