This is for a new SP 2010 install. I have a server running SP 2010. In IIS I have created an empty web site, "share.example.com". In SP Central Admin, I have created a web application bound to the IIS site, and that's working fine. In Central Admin > App Mgmt > Service Apps (shorthand there), I delete the default "User Profile Service" and create a new instance, bound to my web application, and using typical default values, as works in other cases.

My user profile servce gets created, but when I click "Manage" in the ribbon, I get the SP 2010 error screen.

"Error An unexpected error has occurred. Troubleshoot issues with Microsoft SharePoint Foundation. Correlation ID: 7be01822-5ad0-465a-9df2-45fc6a1cb86d Date and Time: 12/5/2011 8:15:57 AM " (the Coorelation ID changes each time).

I have deleted-and-redone that service many times, also changing the name of the re-created service too. No luck. Messed with changing default values, etc. No love. Nothing.

Using ULS Viewer, nothing obvious crosses my path, and I'm not getting much luck with it. Google and Bing have not been my friends on this, although some other posts over on msdn make me suspect it's possibly the web site name != netbios name, but I haven't looked into it yet.

Any suggestions on solving this puzzle?

  • 1) Check to see if the User Profile Service and User Profile Sync Service are running on the server (see Services on Server in Central Admin) 2) In the ULS logs, what is the error associated with that correlation ID? Dec 5, 2011 at 17:34
  • Please anybody have a solution for this error?
    – Andrés
    Jan 24, 2012 at 16:27
  • Could you provide any relevant info from the ULS log with that correlation ID? Also i take it you have waited after creating the UPA, there is a timer job that kicks off every minute that need to run before you can access the user profile management screen. Are both your user profile synchronization instance and user profile service (under services on server) both running? Jan 24, 2012 at 19:47
  • I meet the same issue in my Sharepoint central administration I tried to reinstall all the products but still have the problem Did you succeed in making working the UPS ? Thanks
    – user9171
    Jun 28, 2012 at 13:34
  • i am facing same issue. can you tell me if you find any solution? logs says something like this : "UserProfileServiceImportStatisticsWebPart:LoadControl failed, Exception: System.MissingMethodException: Method not found: 'Boolean Microsoft.Office.Server.UserProfiles.UserProfileImportJob.get_IsSynchronizationR ​unning()'. at Microsoft.SharePoint.Portal.WebControls.UserProfileServiceImportStatisticsWebPar ​t._LoadStatusAndSettings() at Microsoft.SharePoint.Portal.WebControls.UserProfileServiceStatisticsWebPartBase. ​LoadControl(Object sender, EventArgs e)"
    – user10036
    Aug 12, 2012 at 17:19

4 Answers 4



I've not hit your exact issue, but had similar problems. Following the guide at harbar.net has resolved 99% of the problems I've had.


I echo the site mentioned http://www.harbar.net/articles/sp2010ups.aspx for what you need to do to sort out the UPS issues.

I have recently undertaken 2 migrations in the space of 2 weeks and have been finding that if I don't get everything right and unable to start the FIM services the first time the only way I seem to resolve the problem is to apply the August 2011 CU's for SharePoint 2010 / Foundation 2010 and delete + recreate the User Profile Service Application with a different name

  • I ended up rebuilding the whole farm, and going with the www.harbar.net instructions. Still don't have UPSS working even following harbar, but got UPS going and for now I'm happy with that.
    – Alan M
    Dec 13, 2011 at 23:18

Please check build version of your SharePoint Server. We have noticed the above issue mostly with SharePoint environments which are on Service Pack1.

Now check following:

On SharePoint Server navigate to the following:

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\ISAPI\Microsoft.office.server.userprofile.dll

Check the property of above dll(Details tab) and make sure it matches with your 'Configuration db version' (you will find db version under Central Admin > System Settings > Manager Servers in this Farm)

If you see a dll version mismatch, then it is a known issue with SharePoint Server 2010 and you need to upgrade your SharePoint Farm to latest Cumulative Update.

Once you have upgraded to the latest Cumulative Update, you will no longer face this issue.

(Before applying any cumulative update, it is recommended to take full backup of all sharepoint db's and if possible take full farm backup)


=contents=1 and see what web part is on a page. in my case there was a calendar on a page and I tried to open the calendar from list and it was giving me an error. Then I removed the calendar from the page and all is good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.