0

Please provide any help on Usage report values. It's showing all zeros. I have verified below settings. enter image description here

enter image description here

Regards...

0

You can see from the screen shot, Usage and Health data collection proxy is stopped. You have to make sure it is started. To start it run the below powershell.

$sap = Get-SPServiceApplicationProxy | where-object {$_.TypeName -eq “Usage and Health Data Collection Proxy”}
$sap.Provision()

Now you have to wait for 24 hours before see any results.

  • i tried this one. but no luck. – Chandhu Vutukuru Aug 3 '18 at 16:24
  • Is search service application configured and full crawl completed? – Waqas Sarwar MVP Aug 3 '18 at 17:10
  • I'm using intranet site. will this work for Intranet site? – Chandhu Vutukuru Aug 6 '18 at 13:00
  • not it should not cause this issue? as i asked, is search services is up and running, full crawl completed? Usage depends upon on the search? are both search and usage applications are in the same farm? – Waqas Sarwar MVP Aug 6 '18 at 13:53
0

You need to enable usage data collection and health data collection, If already enabled delet it and re-enabled it.

Check the solution here: SharePoint 2013 Usage reports are empty

One more good read post for SharePoint 2013 usages reports.

  • I'm using intranet site. will this work for Intranet site? – Chandhu Vutukuru Aug 6 '18 at 13:00
0

Besides enable WSS_UsageApplication Service, please also check search service web analytics timer jobs,this timer job is used to receive usage and store into search analytics database, you could check this blog for more detailed information:

PowerShell Script to Workaround No Data in SharePoint 2013 Usage Reports

  • i tried this one. but no lock. – Chandhu Vutukuru Aug 6 '18 at 12:54
  • I'm using intranet site. will this work for Intranet site? – Chandhu Vutukuru Aug 6 '18 at 13:00
  • @ChandhuVutukuru yes it should. If it didn't fix your issue then the problem may not be with the receivers. – Chris Odegard Nov 16 '18 at 15:20
0

I had this same problem in an on-prem 2016 farm. In my case, the Usage Service Application was installed and configured correctly, the Proxy was running, and .usage log files were being generated, but the timer jobs that are supposed to import and process the logs were not running. (In troubleshooting I learned that none of the below timer jobs had ever run in the farm.)

Usage Service Application timer jobs

As a result, I was seeing all zeros in the Usage reports, and I was also not able to see Search Service Health reports, either.

The issue for me ended up being that the Usage Service Application instance was disabled on both of my front-end servers. I used the below PowerShell to enable them. The next day, I was able to run usage reports successfully, and I could see in the logs that overnight it had imported some ~90GB of old usage reports into the WSS_Usage DB.

# Get the service instance of "Usage and Health Data Collection Service Application"

$c = Get-SPServiceApplication | Where-Object {$_.Typename -eq "Usage and Health Data Collection Service Application"}

$c.ServiceInstances | Format-List Server, Tynename, Id, Status

The result of the above command:

Server : SPServer Name=CONTOSO-SP-WEB Id : 0b20c83a-7d2d-48f7-9dbc-af316b63fc72 Status : Disabled

Server : SPServer Name=CONTOSO-SP-APP Id : 25d7427a-b95e-4489-9530-fe20a1e07187 Status : Disabled

The next step is to Get each instance by its ID and run its provision() method, which is pretty much the "On" switch.

$c.ServiceInstances.Id | % { 
   $instance =  Get-SPServiceInstance $_
   $instance.Provision()
}

Afterwards, I ran Format-List again on $c.ServiceInstances and this was the result:

Server : SPServer Name=CONTOSO-SP-WEB Id : 0b20c83a-7d2d-48f7-9dbc-af316b63fc72 Status : Online

Server : SPServer Name=CONTOSO-SP-APP Id : 25d7427a-b95e-4489-9530-fe20a1e07187 Status : Online

This post on TechNet (from October 2018) led me to find this solution: SharePoint 2016 Analytics - Usage reports not showing data

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.