From my central admin, manage servers, i could able to see my server but Config cache is not getting updated even though the timer server and SharePoint admin server is started.

When i checked the eventviewer logs, i found below 2 errors.

Database 'SharePoint_Config' on SQL Server instance 'SPSQLServer' is not empty and does not match current database schema

SharePoint object [SPConfigurationDatabase] is in an unsupported state, and could not be used by the current farm. 


2 Answers 2


We had the same issue in one of our production server and running the psconfig fixed it. this command i ran at that time.

PSConfig.exe -cmd upgrade -inplace b2b -force
  • I logged in with my FARM account, and run "Get-SPFARM" command, i get an error "Local Farm cannot be accessible. I could able to do the same from other server in the FARM with same account. Should i try re-installing SharePoint Server on that server? Commented Jul 30, 2018 at 17:15
  • what error you see when you run get-spfarm command on the bad server? its look some permission issue or blockage. could you please check the uls logs and event log for more clue
    – Waqas Sarwar MVP
    Commented Jul 30, 2018 at 17:20
  • I this error when i run get-spfarm Get-SPFarm : Cannot access the local farm. Verify that the local farm is properly configured, currently available, and that you have the appropriate permissions to access the database before trying again. At line:1 char:1 + Get-SPFarm + ~~~~~~~~~~ + CategoryInfo : InvalidData: (Microsoft.Share...SpCmdletGetFarm: SpCmdletGetFarm) [Get-SPFarm], SPCmdletException + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SpCmdletGetFarm Commented Jul 30, 2018 at 18:40
  • I dont see any other errors apart from the above mentioned errors from event viewer Commented Jul 30, 2018 at 18:42
  • are you runinng the command with farm admin account or the same account which is working on other servers?
    – Waqas Sarwar MVP
    Commented Jul 30, 2018 at 18:49

From ULS logs, i got this..

07/29/2018 17:32:55.29 hostcontrollerservice (0x0484) 0x0B74 SharePoint Foundation Upgrade SPConfigurationDatabaseSequence ajyxu ERROR Upgrade object too new (build version = 15.0.4981.1002, schema version = Current server (build version = 15.0.4841.1000, schema version = 00000000-0000-0000-0000-000000000000

the FARM build version is different to farm build version for some reason, installed the last installed CU on FARM and ran PSConfig and everything came backup again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.