3

I had SharePoint 2013 SPD Workflows successfully running on SharePoint 2016 Enterprise Server but recently after enabling the web application with SSL certificate, workflows stop executing. I tried this on 3 different servers, each one throwing different kind of errors. Tried with ULS but did not found any helpful cause of error. Do I need to do any additional configuration at Workflow Manager side to make this working? Or the below article is the solution to my problem?

https://docs.microsoft.com/en-us/sharepoint/governance/install-workflow-manager-certificates-in-sharepoint-server

1

I think you have to re register the Workflow Manager proxy on SharePoint server side as your web application using the SSL while you register workflow proxy with http.

Register-SPWorkflowService -SPSite "https://myserver/mysitecollection" -WorkflowHostUri "https://workflow.example.com:12290" -force

Check this: Install and configure workflow for SharePoint Server

  • Yes I ran the above command but still no luck. Workflows are still not running. Do I need to do any additional steps? – Zakir HC Jul 31 '18 at 12:25
  • what error you are seeing in the logs? also make sure Service bus services running on the WFM server – Waqas Sarwar MVP Jul 31 '18 at 12:31
  • All services are running, I verified in CA and through PowerShell using Get-SBFarmStatus and Get-WFFarmStatus commands. – Zakir HC Jul 31 '18 at 13:20
  • In workflow history list I am seeing this error log for every workflow instance - "System.Net.WebException: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. ---> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure. at System.Net.TlsStream.EndWrite(IAsyncResult asyncResult) at System.Net.ConnectStream.WriteHeadersCallback(IAsyncResult ar) --- End of inner exception stack trace --- at Microsoft.Workflow.Common.AsyncResult.End[TAs" – Zakir HC Jul 31 '18 at 13:21
  • Do we need create a trusted valid certificate for Workflow Manager site in IIS or Workflow Manager service creates a certificate on own and assigns itself? I feel like this all issue is occurring due to certificates. Also followed below this article to troubleshoot but still same issue - c-sharpcorner.com/article/… – Zakir HC Jul 31 '18 at 13:23
1

The solution to the above problem was:

  1. Uninstalled all Workflow Manager and Service Bus Cumulative Updates.
  2. Uninstalled Workflow Manager
  3. Re-installed Workflow Manager.
  4. Attached Trusted Signed SSL Certificate for Workflow Manager (This time I did not use self-signed certificate)
  5. Register the Workflow Service in SharePoint 2016 Management Shell

Register-SPWorkflowService -SPSite "https://myserver/mysitecollection" -WorkflowHostUri "https://workflow.example.com:12290"

  1. Opened SPD 2013 workflows in SharePoint Designer 2013 and re-published each workflow.

The workflows were not visible at first in SharePoint Designer 2013 as we had migrated DB from UAT to production. After installing SPD Service Pack 1 and 8th April 2018 hotfix, workflows were visible in SPD for re-publish.

The key points here is to re-install Workflow Manager and used a trusted signed SSL certificate for Workflow Manager and also for SharePoint web application and finally re-publishing the workflows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.