3

I have a document library in SharePoint site. Under the Advance settings option of library setting I have set "Allow management of content types?" option to yes as shown below enter image description here

And I have selected "Make 'New Folder' command available?" option as No. enter image description here

So in the document library page, under the Files menu in ribbon the "New Folder" option is disabled.

enter image description here

But when I am clicking on the "new document" option like below: enter image description here

Then the "New Folder" option is visible and enabled in the popup as shown below: enter image description here

Screenshot of the Content Types under Document settings: enter image description here But according to the setting it should not be visible or enabled. I am not sure why it is behaving like this. Is this a bug in SharePoint or is it the expected behavior? Any suggestion would be helpful.

  • I tried this at my SPO and Its not showing 'New Folder' in drop down as well for me. Works fine with me. Not sure about your specific case. Try this by creating new library and apply setting there. – Bhaskar Dhone Jul 27 '18 at 9:47
  • Thanks for your response. Yes I have tried with new library also. It is behaving the same way – Harsh Jul 27 '18 at 10:12
  • Check content types - do you have a Folder content type? – Tally Jul 27 '18 at 10:43
  • Yes we have folder content type. So is it because of that? – Harsh Jul 27 '18 at 11:28
  • It could be. What happens if you set the folder content type to 'hidden' or 'read only'? I think it may disappear as an option; so you'd still be able to select Word, Excel, Powerpoint and Onenote, but the Folder option would disappear. – Tally Jul 27 '18 at 13:09
1

A content type is a 'type of content' (this could be an Excel document, a folder, an image, a document set, a web page, an item and so on - all things that can be saved in to a List or Document Library in Sharepoint.

If you do not 'allow management of content types' the document library will revert to 'default settings'. For me, in my SharePoint 2013 system, the default settings for a document library would be a single document type - either Word or Excel.

I think you need to see what kind of content types you have in your list - are there 5? One each for Word, Excel, PP, One Note and folder? If so, you should be able to set Folder to 'hidden' or even delete it from your document library. This way, you can keep content types enabled, so users can choose from the remaining 4 content types.

Here's how to get to the content type settings:

In my example I have 4 content types enter image description here

If I select the document content type - I can see which template the document content type is using enter image description here

As we see here, it is defaulted to use a .dotx - the 'tx' means it is a template, the '.do' part comes from .doc (Word doc). enter image description here

I hope this helps a bit

  • Thanks for your response. I checked content types in the settings. But there is no content type in which something related with Folder is mentioned. – Harsh Jul 30 '18 at 9:16
  • Would you mind posting a screen shot of your Content Types - from your Document Library settings screen? – Tally Jul 30 '18 at 10:16
  • Added. Please check the updated question. – Harsh Jul 30 '18 at 10:36
0

I have done a test in my SharePoint 2013 and SharePoint online and i cannot reproduce your issue, If i select "Make 'New Folder' command available?" option as No, then the "New Folder" option is not visible in the popup as shown below:

enter image description here

What is the build number of your SharePoint 2013? Try to install the latest cu in your farm.

  • Is "Allow Management of content types?" under "Advance Settings" is selected or not? – Harsh Jul 30 '18 at 10:09
0

Bit late but somehow I am able to solve my issue. Now I am just handling the click event of the new document button. So when ever user is clicking on the button, I am checking whether the Make New Folder command available? is enabled or not. If not then I am hiding the button. This code I have written in masterpage js file. which is available throughout the site collection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.