3

I am on SharePoint 2016 on prem and working with a list of document set libraries that are each shared by a large group of people.

The Problem: I created a new permission level that allows editing, but not adding or deleting. In my tests, the person who is getting this custom permission is able to add and delete files, but her actions do not actually effect the document library - it just APPEARS that it does to the person doing the adding/deleting. In my tests, I am in the document set at the same time and refreshing the page, but am not seeing any changes to the files. The problem is that I don't want people to be confused thinking that they can add or delete (b/c it looks to them like they added/deleted) when in actuality they cannot. A message does appear saying that that the user doesn't have permission to add/delete, but the files still look added/deleted to them, so there is confusion.

My question is: is this normal? Is there a way by using permissions to not give people the option to add/delete?

Thanks for your help!

1

WRONG PERMISSIONS LEVEL !!!! you have to give them the "Edit Items" permission, the edit permission actually gives them permissions for management, that's the reason they see the "add/delete" options

If the users are still seeing the Edit items option, then you should provide a Wiki page instead of the list view page to the users

1.- Create a new Wiki page
2.- Add a list view webpart of your List
3.- Click on web part properties
4.- on the first options on toolbar select : "no toolbar"

That will remove the the add new documents.

further steps :

5.- on the advanced tab on the webpart properties remove the Title URL or place the same url of the page as the title URl , this way they won't be able to navigate to the library.

Provide this page to the people that cannot add items instead

You can apply this same properties to the list view, but that would remove also the capability of anyone to add new documents,

Also if they create a view out of that view they will recover the add item button

  • I'm sorry - I don't understand. I thought I had given edit items permission. The screenshot below shows the list permissions I have selected. Is this not right for allowing editing, but not adding or deleting? – Fitzgerald Jul 30 '18 at 12:59
  • I'm sorry - I can't add screenshots (I'm new to this forum still). I thought I had given edit items permission. Under List Permissions I have selected: Edit Items, View Items, Approve Items, Open Items, View Versions, Create Alerts, and View Application Pages. You'll notice that I did NOT choose add items or delete items. Is this not the right permissions for what I am needing? – Fitzgerald Jul 30 '18 at 13:11
  • interesting, if you are giving them only "edit item" they should not see the "add new item" option, I'm updating my answer – Mike Jul 30 '18 at 14:47
  • Thank you - I'll take a stab at the instructions you wrote above. Appreciate the help! – Fitzgerald Jul 31 '18 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.