1

I'm using the Promoted Links tiles (that open in a modal dialog) with direct links to MP4 files in an adjacent Assets library called vlog e.g:

http://sitename.com/vlog/video1/video1.mp4

Everything is out of the box except for some CSS to adjust the video size.

This all works beautifully in Chrome & Firefox but (surprise!) when I click a Promoted Link tile in Internet Explorer it gives me a Save As prompt for the video file.

If this is an IE setting I can't seem to find it. Any pointers would be appreciated :)

NOTE: If I go to Internet Options > Security > Local Intranet > Custom Level... and set File Download to Disable it changes the behaviour and I get a "not permitted" message instead of the Save As prompt.

NOTE: In Central Admin I've already got Browser File Handling set to Permissive.

  • AFAIK the setting that should be adjusted is something you'd typically need to do at local-level, so for external users... well, not much can be done. For internal users it would be handled in group policy. Even the latter isn't nice to handle. While this may be outdated, the issue could still be in e.g. codecs. A somewhat generic solution would probably be to add a custom media player which is used with the videos, as I'd expect there to be one which plays mp4s regardless of base-settings and browser. Nevertheless, this isn't really an SP specific issue. – moe Jul 24 '18 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.