1

I try to deploy my first Field Customizer app to a SharePoint online tenant. Tried several things, without CDN and with bundled assets, now using a CDN (which I previously configured with the SharePoint Online Management Shell). Nothing worked. There are warnings and 404s on the JS console, it seems that the field-customizer js file is not loaded.

enter image description here

What I did:

  1. I added the CDN base path to config/write-manifests.json

  2. I set "includeClientAssets": false in config/package-solution.json

  3. gulp clean

  4. gulp --ship

  5. I copied the files from <myprojectpath>/temp/deploy to my CDN location

  6. gulp bundle --ship

  7. gulp package-solution --ship

  8. Upload and activate .sppkg file

  9. made sure that the latest version is running on the target site

Did I miss anything? Are there any other relevant config settings I need to change? Is a CDN necessary at all, can't sharepoint 'automatically' host the js files somewhere when I include them in the package (like in a sharepoint 2013 hosted app)?

UPDATE:

I decided not to host the assts (which is basically one script) in the CDN but bundle it and deploy them directly, I learned that it should be possible.

But still I don't know how to actually attach the field customizer to a specific field of a specific list. Maybe that's the issue. In local hosting debug mode you do it with lengthy URL parameters, but how to do it in production?

  • I can only see a 404 for the graph call. Have you activated the feature? Have a look in the docs for how you deploy extension. docs.microsoft.com/en-us/sharepoint/dev/spfx/extensions/… – Anders Aune Jul 24 '18 at 10:48
  • @AndersAune I followed that tutorial to build the extension. I worked after some certificate issues when hosted locally. I also followed the deployment steps and that is what I ended up with. – elsni Jul 24 '18 at 10:51
  • @AndersAune nope, no idea what the graph call is for – elsni Jul 24 '18 at 11:01
  • Did you add the app? Have you checked the network tab to see if your js file has been loaded? The 404 above and the other warnings don't seem to be relevant. – Oak3 Jul 24 '18 at 11:51
  • @MartijnEikelenboom, yes the app is added (latest version). My js file is not loaded at all. – elsni Jul 24 '18 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.