3

I have created a Site Collection "Demo" on the Default "SharePoint - 80" web application.

The web server IP is x.x.x.37 and the DNS entry for that is sp-apps.portal.com.

How can I enable users to access the site collection using URL like "http://sp-apps.portal.com/sites/Demo"

2

You need to configure Alternate Access Mapping in Central Admin. Here's a detailed description on how to do this: https://docs.microsoft.com/en-us/sharepoint/administration/configure-alternate-access-mappings

  • Hi Martijn, The DNS entry Needs to be made against the Server or the specific web application – apurva mishra Jul 23 '18 at 13:41
  • Also as I understand from the link ,do I need to change the public URL for the web application as per my understanding the public URL was already created when the webapplication was created. – apurva mishra Jul 23 '18 at 13:48
  • You also need to check/edit your bindings on IIS on the web-front-end of you SharePoint farm. Make sure that the host name is resolved and redirected to the right address. I forgot that this is not done automatically. See: blog.blksthl.com/2012/12/03/… – Oak3 Jul 23 '18 at 14:33
  • Hi, I have done the necessary AAM and IIS binding entries but still the URL is not opening using DNS entry... do you Thing that it might be an issue because the webapplication URL was created using Server hostname , for the current SharePoint -80 webapplication the URL is "http: //utcadd007/". The site collection opens with URL "http ://utcadd007/sites/Demo" but still not opening with URL "http ://sp-apps.portal.com/sites/Demo" – apurva mishra Jul 27 '18 at 12:21
0

As mentioned you have to configure the your DNS with IIS (if you have SSL) and Alternate Access Mapping.

  • Your DNS entry (sp-apps.portal.com) should point to your Web Front server where the Web Application is provision.
  • Now you have to update your AAM settings
    • Go to the central admin --> Application Management --> Configure Alternate Access Mappings
    • On this page Select your Web Application and click Edit Public Urls
    • Now replace the Url in Default zone by sp-apps.portal.com
  • If you are using the SSL, then you need a SSL cert. You have to bind the SSL cert in IIS with the web application.
  • Can you please let me know that the DNS entry should be made against the webserver or the WeBapplication URL. In my case the webapplication URL is https:.. – apurva mishra Jul 23 '18 at 14:49
  • You need a record..sps2013.blogspot.com/2013/09/… – Waqas Sarwar MVP Jul 23 '18 at 15:01
  • Hi, I have done the necessary AAM and IIS binding entries but still the URL is not opening using DNS entry... do you Thing that it might be an issue because the webapplication URL was created using Server hostname , for the current SharePoint -80 webapplication the URL is "http: //utcadd007/". The site collection opens with URL "http: //utcadd007/sites/Demo" but still not opening with URL "http: //sp-apps.portal.com/sites/Demo" – apurva mishra Jul 27 '18 at 12:21
  • what is your AAM settings, can you share – Waqas Sarwar MVP Jul 27 '18 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.