2

I invited an external users to our SP site and when they clicked on the link found in the email invite they get "You need permission to access this site." Obviously, I gave them access otherwise they would not have received the email invite, but yet they still get "You need permission to access this site." Is there a reason why?

2

There are a huge number of reasons why they get that error message but the most common one seems to be that they are logging in with a wrong account or that the default page of the site is not shared with external users 😒

  • They are logging in with the email that I sent the invite to. The default page is also shared with external users. I created a new permission group that doesn't allow users to edit pages. They can only view pages and can contribute to list and libraries. Could this be the issue? Really appreciate your help! – NET Jul 18 '18 at 15:32
  • Well, to rule out that the custom permissions are the reason I'll just assign plain old Contribute to the externals, and see if that changes anything. – Kasper Bo Larsen Jul 18 '18 at 15:39
  • Thank you. I will give that a try. I just don't want "Contribute" to be able to edit pages. How do you accomplish this? – NET Jul 18 '18 at 15:48
  • Breaking the permissions on the page library 😉 – Kasper Bo Larsen Jul 18 '18 at 15:50
  • I tried that, but it didn't work. Let me try that again. Thank you thank you for taking the time to respond. – NET Jul 18 '18 at 15:52
1

i think you must create specific group and add this account to it and then send invited link for he/she to Sharepoint site .

  • 1
    I will try that. What I previously did was modified the Members-Edit SharePoint Group and assigned it the new permission group I created. I will let you know if what you recommended works. – NET Jul 18 '18 at 17:33
  • 1
    It resolved the issue of them accessing the site. Thank you. The reason I created the new group is because I didn't want them modifying pages only be able to modify list and libraries. I did this because breaking page inheritance didn't work. Unfortunately this solution doesn't work either. – NET Jul 18 '18 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.