SharePoint keeps asking for password in IE and Chrome after changing the service account domain\serviceapp.

After changing the password we updated the password in IIS and Central Admin Managed accounts and restarted the servers and services and did an IISRESET too, but it is still asking the password

  • Which service(s) uses this service account domain\serviceapp :s credentails?
    – Benny Skogberg
    Jul 13, 2018 at 12:25
  • Microsoft SharePoint Foundation Application Pool: SharePoint_80_4d4295d78d954747a9e599ecca7caa4c Microsoft SharePoint Foundation Application Pool: SharePoint_80_5e060b36742c49ec9a8ea88cd6040ac6, Subscription Settings Service, App Management Service, BDC, Managed Metadata Service, PerformancePoint Service, Secure Store Service, SSRS, Excel Services, User Profile Service, for this services we are using that account
    – karthik
    Jul 13, 2018 at 12:37
  • is central admin & sharepoint timer service also running under that account?
    – Waqas Sarwar MVP
    Jul 13, 2018 at 13:43
  • no central admin & sharepoint timer service not running under that account
    – karthik
    Jul 13, 2018 at 16:22

4 Answers 4


we are using negotiate kerberos authentication in sharepoint, changing the service account password some how removed the SPN's, again reconfigured the SPN for that service account and reconfigured the service accounts for web-application pool and IIS reset worked

thank you all for your help


From the article SharePoint 2013: How to change all service account passwords, this is what should have happened. I'd suggest to restore the old password first, and then follow these steps exactly:

SPAPP - Change the Application Service Account Password


  1. Standard domain account.
  2. This account is generally used as the content web application pool identity.
  3. May also be used as the identity for the Work Management Service Application (WMSA).


  1. Managed (if used for content web applications and WMSA)


  1. Change the password in AD Users and Computers as you would normally.
  2. Restart all farm servers on which SharePoint is installed.
  3. Next, remote into any SharePoint server using the SharePoint Setup User Administrator account (eg, spAdmin).
  4. Test content web applications by trying to connect to them. You should see HTML 503 Service Unavailable messages in the browser.
  5. Remote into a farm application server using the SharePoint Setup User Admin Account (eg, spAdmin).
  6. Launch Central Administration.
  7. Navigate to: CA > Security > General Security > Configure Managed Accounts.
  8. Look for the App service account, and then click the Edit icon next to the title.
  9. In the Credential Management section, check Change password now.
  10. Next, also in this section, select Use existing password and then enter the password.
  11. Scroll down, and then click OK. The page will be busy for less than a minute. Once it returns, move on to the next step.
  12. Remote into a WFE.
  13. Launch an elevated command shell.
  14. Execute IISRESET, and then wait for it to complete.
  15. Repeat steps 12-14 for each WFE in the farm.
  16. Try connecting to each of the content web applications of the farm. You may get the usual "Sorry...". This is expected and is due to time out behavior: the IISRESET initiates a complete recompile of each of the web applications on the WFEs. Keep trying.
  17. Once you verify the content web applications are back up, try hitting your My Site and your OneDrive. Here too you may experience errors presented in the browser. This is expected. The My Site web application was also recompiled (if they are co-hosted with your content web applications).


The SharePoint App service account (spApp) is typically used with content web applications and the Work Management Service Application (this is created and configured automatically for you during normal install). Managing this web application AppPool identity via SharePoint Managed Accounts makes changing this particular password a snap. An IISRESET is absolutely necessary after restarting SharePoint servers and then changing the password in Managed Accounts. if you don't do this, you'll experience 503 Service Unavailable errors.

  • i already did this procedure, Credentials prompts after changing service account password for all user and some able to logon through chrome not all. all users are unable to logon through IE
    – karthik
    Jul 13, 2018 at 16:26

Try to set ‘Automatic logon with current user name and password in Local intranet zone and Trusted sites of IE:

Navigate to IE->Internet options->Security tab->Local intranet and Trusted sites->Custom level->choose automatic logon with current user name and password:

enter image description here

Check the following article:



Try following steps :

  1. Close all the instances of IE.
  2. Go to Control Panel -> User Accounts -> Credential Manager
  3. Remove all your windows and web credentials.
  4. Restart the machine and try accessing SharePoint sites.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.