0

I have a content type with some columns. However when I add the content type to a list, not all columns are showing. I have checked the columns and they contain the value Yes under Update all content types inheriting from this type?

Why are they not showing? They are showing just fine in another subsite.

Update: Columns are site columns and some of them were set to hidden by someone.

Even though I set them to visible, the changes are not reflecting down in the list.

  • 1
    The columns should be created as site columns in a hierarchy level which is above the site you are planning to use the content type. So if you have a parent site A and a subsite B which would both use this content type, the site columns need to be created at site A or above. The setting-option you mention shouldn't affect anything - it's used to update site columns at whenever they are being used, if the column is changed at the site column's settings (i.e. not in list level). – moe Jul 13 '18 at 10:10
  • Sounds like my suggestion to check for hidden columns was right. If I understood correctly you set the columns to 'not hidden' at the Site level, but did not initially change this at the List level. – Tally Jul 27 '18 at 11:30
  • Hi Burre, would you mind marking the Question as Answered? Or else post an Answer if you found another way of solving this? This would benefit other users too. Thanks – Tally Aug 7 '18 at 11:46
  • 1
    I can't mark it as answered as it is not solved yet. I don't have answer for it yet. Still it does not show why the changes are not pushed down to the list. – Burre Ifort Aug 7 '18 at 12:02
0

Did you create the Content Type at the Site level? Does the Content Type contain only site-level columns?

Perhaps the CT contains list columns from what I'll call List A. You would need to recreate these list columns on List B for the content type to be able to find and use them. You could compare your new list vs the sub-site list you mentioned - do you see all the same columns names in both places?

The only other thing I can think of is columns that are set to 'hidden' - you can check that in the content type itself, click on it in the list settings and review whether any columns are set to 'hidden'.

  • it was set to hidden and I changed it to optional, but still is not showing up at the list level. By the way I changed the option at the site content type level. – Burre Ifort Jul 13 '18 at 10:22
  • Is there any custom coding that hides certain columns? Edit page -> look to see if there are any web parts containing code. Although if you set this up yourself and nobody else can edit pages, then it's safe to say it won't be custom code hiding things. BTW - since your content type is shared across multiple lists, you'll need to re-hide the hidden columns, but I guess you know that already :-) – Tally Jul 13 '18 at 10:41
  • there is nothing custom. – Burre Ifort Jul 13 '18 at 10:47
  • As Moe mentioned too, you need to determine whether the content type contains any 'List columns'. If a column is list-specific and is added to a content type, the list-columns can not be moved to another list. If you go in list settings>Columns - do you see all the same column names in 'List B' and 'List A'? If you do not, that would mean that the CT has some list columns in it (in addition to the site columns). Reading the first part of this blog post should help to illustrate what I mean – Tally Jul 13 '18 at 11:05
  • these are site columns and there are not list columns at all. – Burre Ifort Jul 13 '18 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.