3

I'm experiencing an issue that is directly related to this question posted here (https://collab365.community/forum/topics/sub-folder-content-types-set-wrong-in-document-set-library/):

I have a SharePoint Online Document library that contains only the out-of-the-box “Document Set” content type. Using the Ribbon I create a new Document set and then open it. From the ribbon I then click the “New Folder” button and a new folder is created as expected.

Examining the properties of the new folder I find that SharePoint has assigned the Content Type to be “Document Set” and not “Folder” as I would expect. SharePoint does provide the ability to change the content type to Folder using the Content Type dropdown selector in the Edit properties form.

How can I configure the Library to use “Folder” content type instead of “Document Set” content types when users create new folders?


I don't see a solution.

The Document Set settings lists Document as the only "Content types allowed in the Document Set". Folder isn't even an option on the Document Set settings page, only Discussion and Summary Task, which are both children of the Folder content type, but then why wouldn't Folder be listed? On the Site Content Types page there exits a "Folder Content Types" group and Folder is listed (Item is the parent)?

To further this peculiarity requires looking at the edit properties form. When going into the newly created "folder", which has the Content Type set to Document Set, the Content Type can be changed to Folder. I found this peculiar, since (again) Folder isn't listed as the "Content types allowed in the Document Set" on the Document Set Settings page.

Has anyone experienced this that can lend a hand? I have different instances of SharePoint on-prem and some create a Folder as expected and some create the Document Set. I can't determine the differences between their settings, or if this is just corruption. I need to determine if this is a setting that can be changed (perhaps farm/SCA-only?) and how to do that.

Thanks in advanced

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.