4

I just finished the installation of SharePoint 2016 using AutoSPInstaller. Everything works fine except when I want to open any document in a document library which contains the character ''é'', ''à'' and other character with accent in the 'Name' column. I receive the message ''Can't connect to.......Check that the web address you are using is correct...''. This happens whether I use a french site collection or english site collection. It works well on my dev farm, but not in my others environments. Once I remove the character, the document opens just fine.

Additional information : When I tryed to open a document with the character 'é' in the 'Name' column in my farm with Office Online Server, I receive a 'Page not found error'.

Additional information : Preview of the document works

Additional information : As weird as it seems, if I use '`' or '^' or any special character, documents open well. The problem is only when they are with a letter(like 'é','è')

enter image description here

  • Is it a migrated document, an uploaded document or a created document using Office Online Server (previously Office Web Apps)? – Benny Skogberg Jul 11 '18 at 12:55
  • It happens no matter the situation. Only needs a 'é' or 'à' in the 'Name' and the document can't be opened. In this specific example, it is an uploaded document. – Charles Simard Jul 11 '18 at 13:02
2

My colleague found the solution. You need to enable ''Allow high-bit characters'' in your IIS Web Site in the Request Filtering option.

1

If you're on a Windows operating system other than Windows 10, you may have a problem with the URL which doesn't translate the àçéèêëïù correct. Instead of using % it may use invalid characters such as à çéèêëïù.

Things to try:

  • Open the file in SharePoint directly from Word, and not the browser using Words File > Open command.
  • While in classic and not modern mode in SharePoint, navigate to ... > Open with Word.

Reference: Can't open files from Office 365 if name contains accents (Windows 7/IE11)

  • Tried this, but it doesn't work. – Charles Simard Jul 11 '18 at 13:39
  • @CharlesSimard And if you change the name of the file to not include these characters? – Benny Skogberg Jul 11 '18 at 13:40
  • If I don't use these characters, it works just fine. The problem is the company I work for has more than 5k employees and they all used 'é' and 'à' in the 'Name' of their documents on SharePoint 2010(we are migrating to 2016). So, in fact, not using those characters is , sadly, not an option. – Charles Simard Jul 11 '18 at 13:42
  • @CharlesSimard Then you have two options. 1) Switch to Windows 10 (preferred) or 2) keep on using SharePoint 2010 – Benny Skogberg Jul 11 '18 at 13:44
  • The problem is that it works very well on my 'Test' farm, but not on the other farm. – Charles Simard Jul 11 '18 at 13:46
0

The problem comes with a windows security update: KB4489899

Possible Solutions:

  • Uninstall Update
  • Use Edge, Chrome, …
  • Set the following registry keys (maybe you have to adapt the key to your office version):

    [HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Internet] "FSSHTTPOff"=dword:00000001
    "FSSHTTPSOff"=dword:00000001

Caution: The registry key will force office to access SharePoint via WebDAV instead of SOAP! Further information: https://support.office.com/en-ie/article/using-the-fsshttpoff-registry-key-fd193fa2-9b23-4e60-8527-1bf760b2d470

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.