1

I have a Sharepoint 2013 environment that has configured a BLOB cache, so that it caches all PDF files. This is configured on the 2 WFE. After the configuration, I have experienced that, if you overwrite a PDF file with a new version and then open the PDF in the browser, it will still open the old version.

If I download the file and open it in adobe, it will show the new version.

When I go to the location of the BLOB cache, I cannot find the PDF file, even though I have opened the PDF file from SharePoint. All the other files from the same Document Library are shown, when they have been opened.

For now I have tried to clear both browser-, BLOB- and SharePoint cache. Nothing worked.

Has anyone else experienced this issue?

0

The item is most likely cached on the client.

This is done if you have set a "Max-Age" in the Blobcache configuration. If this is set the client will not talk to sharepoint in order to see if there was an update to the document. This allows you to reduce the "freshness checks" against your server.

Try using fiddler or F12 to see what actually happens. Have a close look at the response codes there. Also you can set a flag in the F12 Dashboard to ignore cache and retrieve it from the server (Always refresh from Server on the Network tab)

  • The 'Max-Age' property is set to 0. Would it be recommended to remove the property, or should it be set to something specific? – Nicklas Storm Jul 10 '18 at 7:21
  • I used F12 to disable the cache, and it worked. it showed the correct document. i also have used Fiddler to check the response code, and it says '304 NOT MODIFIED' – Nicklas Storm Jul 10 '18 at 7:23
  • setting max-age allows you to skip "freshness checks". which will reduce some calls to SP. It might be wanted, but applies to all cached files. The duration should be reasonable (a day?) If you have complex pages and/or high latency it can remove some requests.. – Heiko Hatzfeld_MSFT Jul 10 '18 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.