1

I have two SharePoint 2016 Farms where i can reproduce the following issue:

  • Farm needs a minimum of two Servers to reproduce. Example: WFE01 holds CentralAdministration, APP01 hosts all Search components.
  • If i open the Search Administration page in CentralAdministration on APP01 or any server than WFE01, the System Status Webpart needs about 10 Seconds to load.
  • If i open it on WFE01 (which also hosts CentralAdmin), the Webpart loads instant.
  • I wasn't able to find any user-affecting impact by that behavior. But i'd still want to know whats going on in behind.

Search Administration load behavior

More Information:

  • In ULS-Log i can find the following error twice in an interval of 5 seconds: Exception getting analytics progress: Failed to connect to system manager. SystemManagerLocations: net.tcp://Server2/F2425C/AdminComponent1/Management

    07.03.2018 06:46:08.13  w3wp.exe (0x0EA4)   0x3048  SharePoint Server Search    Administration  dn28    High    SearchAppSystemWebPart: SSA Status - 00:00:00.  320a779e-4e2b-903c-2071-08153ac4590b
    07.03.2018 06:46:12.77  w3wp.exe (0x0EA4)   0x3048  SharePoint Server Search    Administration  ai4f3   High    [Forced due to logging gap, cached @ 07/03/2018 06:46:08.13, Original Level: Verbose] Got new systemmanagerlocation from db net.tcp://syfsrvspapp01/F2425C/AdminComponent1/Management   320a779e-4e2b-903c-2071-08153ac4590b
    07.03.2018 06:46:12.77  w3wp.exe (0x0EA4)   0x3048  SharePoint Server Search    Administration  ai105   High    Exception getting analytics progress: Failed to connect to system manager. SystemManagerLocations: net.tcp://syfsrvspapp01/F2425C/AdminComponent1/Management    320a779e-4e2b-903c-2071-08153ac4590b
    07.03.2018 06:46:17.41  w3wp.exe (0x0EA4)   0x3048  SharePoint Server Search    Administration  ai105   High    Exception getting analytics progress: Failed to connect to system manager. SystemManagerLocations: net.tcp://syfsrvspapp01/F2425C/AdminComponent1/Management    320a779e-4e2b-903c-2071-08153ac4590b
    07.03.2018 06:46:17.41  w3wp.exe (0x0EA4)   0x3048  SharePoint Foundation   Topology    e5mc    Medium  WcfSendRequest: RemoteAddress: 'https://syfsrvspapp01:32844/3be058e52354477282bd395528b6053f/SearchAdmin.svc' Channel: 'Microsoft.Office.Server.Search.Administration.ISearchApplicationAdminWebService' Action: 'http://tempuri.org/ISearchApplicationAdminWebService/IsDeleteCrawlInProgress' MessageId: 'urn:uuid:c9b9c56f-6ba0-481e-95cb-4f45778e5f0c'  320a779e-4e2b-903c-2071-08153ac4590b
    07.03.2018 06:46:17.42  w3wp.exe (0x168C)   0x154C  SharePoint Foundation   Topology    e5mb    Medium  WcfReceiveRequest: LocalAddress: 'https://syfsrvspapp01.ad.syrface.de:32844/3be058e52354477282bd395528b6053f/SearchAdmin.svc' Channel: 'System.ServiceModel.Channels.ServiceChannel' Action: 'http://tempuri.org/ISearchApplicationAdminWebService/IsDeleteCrawlInProgress' MessageId: 'urn:uuid:c9b9c56f-6ba0-481e-95cb-4f45778e5f0c'  320a779e-4e2b-903c-2071-08153ac4590b
    07.03.2018 06:46:17.43  w3wp.exe (0x168C)   0x154C  SharePoint Foundation   Micro Trace uls4    Medium  Micro Trace Tags: 0 nasq,0 e5mb 320a779e-4e2b-903c-2071-08153ac4590b
    07.03.2018 06:46:17.43  w3wp.exe (0x168C)   0x154C  SharePoint Foundation   Monitoring  b4ly    Medium  Leaving Monitored Scope: (ExecuteWcfServerOperation (https://syfsrvspapp01.ad.syrface.de:32844/3be058e52354477282bd395528b6053f/SearchAdmin.svc)) Execution Time=22.0717; CPU Milliseconds=8; SQL Query Count=0; Parent=None    320a779e-4e2b-903c-2071-08153ac4590b
    07.03.2018 06:46:17.44  w3wp.exe (0x0EA4)   0x3048  SharePoint Server Search    Administration  dn29    High    SearchAppSystemWebPart: BackGround Status - 00:00:09.   320a779e-4e2b-903c-2071-08153ac4590b
    07.03.2018 06:46:17.44  w3wp.exe (0x0EA4)   0x3048  SharePoint Server Search    Administration  dn2a    High    SearchAppSystemWebPart: Crawl Rate - 00:00:00.  320a779e-4e2b-903c-2071-08153ac4590b
    
  • Search is working as expected. No errors in Topology, Crawling, Querying, etc.

  • A RunAllTestsof SRx-Core shows no errors: SRx-Core Results

My Questions:

  • Anyone who can reproduce this issue?
  • Could this affect users?
  • Any explanation on what's going on in behind?
  • Maybe even a solution how to get rid of that!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.