I've created a task list with a retention policy that runs a workflow on due date. the workflow is just 1 single action to send an email to the person assigned to. If I manually start the workflow it does send the email. However for all other tasks the users are not getting any email that is supposed to be sent by the retention policy on due date. Any Ideas why? I am using Sharepoint foundation that is included in Office 365 subscription. Te workflow is 2010 Retention Policy


1 Answer 1


There are 2 timer jobs in SharePoint that manage the Information Management policy. Expiration Policy timer job, which determines which items are expired based on rules, and Information Management Policy, which actions the expired items by running the rules. These jobs are run weekly by default. In SharePoint on premise you can manage how these jobs are run, but unfortunately you cannot do that in SharePoint Online.

In your case I believe, most likely you have to wait a maximum of two weeks for the email to be sent. To check when the timer jobs were run last connect to the SharePoint online site using SharePoint Designer. On the home page click on Site Options in the top ribbon. then check the following two properties:


which mention when each job was run last time and wait for them to run next and hope the email is sent :)

From what I understand from your business requirement, you might want to consider not using the information management policy at all, and handle the wait operation in your workflow using the workflow action "Pause until date" and set the due date.

  • Thanks @Paiman, Looks like I have no choice but use the Pause until date action in a workflow, although I read that this action takes a lot of resourser on the server, would I be concern about this? Jul 2, 2018 at 7:06
  • 1
    The pause until date uses the "Workflow" timer job in the back of the scenes which is run every 10 minutes if I recall correctly. Unless your site is not going to be loaded with many tasks every 10 minutes, I think it should be fine. Jul 2, 2018 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.