1

I've created a new test farm. I have the default Web Application and Root Site Collection that were created with Config Wizard which I can browse perfectly fine at sp16-01.vanguard.com:

enter image description here

If I create a new Web Application, using default settings & authentication (NTLM), with a new Root Site Collection with a name that I want e.g. white.vanguard.com:

enter image description here enter image description here enter image description here

I'm unable to browse the Root Site Collection. I message that is returned is:

"Server IP address could not be found"

I've tried the following with no success:

  • Adding an A record in DNS to point white.vanguard.com to the WFE IP,
  • Enabled Anonymous Access,
  • Giving Full Control in User Policy for the Web Application

When I add the A record in DNS I am prompted for authentication but none of my accounts work (SPFarm, SPAdmin, Administrator).

I'm missing a step here. Could someone please enlighten me?

EDIT: Added screenshots below for AAM, DNS, IIS and Hosts file. As mentioned this is out of the box. I've tried A record and CNAME in DNS, AAM entries, bindings and hosts file entry but cannot get the site to load.

EDIT2: I'm trying to browse the site from the WFE.

enter image description here enter image description here enter image description here enter image description here

  • 1
    What authentication scheme do you use? Kerberos or NTLM? Did you create a new site collection inside the new Web app? – Evariste Jul 1 '18 at 6:18
  • @Evariste I've updated my post. I did create the Site Collection and the authentication is default NTLM – Rubio Jul 1 '18 at 6:22
  • You'd also need to add white.vanguard.com as an Alternate Access Mapping (as a public address). However I'm not sure this is the actual problem here. – Evariste Jul 1 '18 at 6:26
  • @Evariste An AAM to what though? After the SC is created an AAM entry is already created for white.vanguard.com to white.vanguard.com. This is an out of the box farm so there has been no changes to the default configuration. – Rubio Jul 1 '18 at 6:33
  • 1
    @Rubio Are you trying to access the site collection from the server itself or from some other machine? If trying from the SP-Server you might need to either DisableLoopbackCheck (not recommended) or add white.vanguard.com(:34535) to the BackConnectionsHostnames in Registry. For both see support.microsoft.com/en-us/help/926642/… – ben Jul 2 '18 at 7:08
1

After discussion in the comments it showed that you are trying to access the site-collection http://white.vanguard.com:34535 locally from the web-frontend server itself.

Windows Server prevents such back connections, that is accessing locally hosted websites via other hostnames than localhost or the server's "real" hostname (here sp16-01) or FQDN.

In such cases you have to add the desired additional FQDN (here white.vanguard.com) to the list of allowed BackConnectionHostNames in the windows registry under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0. If there is no entry BackConnectionHostNames, you have to create it as multi-string value.

Alternatively, you can completely disable loop back checking by creating the DWORD-entry DisableLoopbackCheck with value 1 under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa. But beware that this is not recommended as it disables a security feature.

| improve this answer | |
  • This is precisely the step I was missing! Thank you! In addition to this registry change you would also need to add a hosts file entry: 127.0.0.1 white.vanguard.com – Rubio Jul 7 '18 at 16:52
1

As per the screenshots you posted, the new Web application you created is hosted on port 34535, making the complete URL http://white.vanguard.com:34535 and not http://white.vanguard.com.
You should have created the Web application on port 80 to be able to browse it with http://white.vanguard.com.
Either delete and re-create it on port 80, or try to update the current port from 34535 to 80 with PowerShell (here is the PowerShell code to read the port number, you can aybe adapt it to set the port number: https://sharepoint.stackexchange.com/a/150967/35604).

| improve this answer | |
  • Even if I browse to http://white.vanguard.com:34535 there is no success. Referencing the first screenshot, if I delete the other Web Application on port 80 and create a new white.vanguard.com WA & SC on port 80 again there is no success. The error in Chrome is: white.vanguard.com’s server IP address could not be found ERR_NAME_NOT_RESOLVED – Rubio Jul 1 '18 at 7:54
  • Let's assume the error message tells the truth (which I believe): there's most probably a DNS error. Can you try pinging white.vanguard.com? What's the result? – Evariste Jul 1 '18 at 9:30
  • PS C:\Users\Administrator> ping white.vanguard.com Ping request could not find host white.vanguard.com. Please check the name and try again. – Rubio Jul 1 '18 at 15:40
  • If I add a hosts file entry for the server IP and the host header (10.0.0.198 white.vanguard.com) I will be prompted for a password when I browse to the site. However the password prompt just keeps looping. – Rubio Jul 1 '18 at 16:12
  • Added some more screenshots to the original post. – Rubio Jul 1 '18 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.