1

I get this error in SharePoint 2016 when I run below command to migrate project DB and create PWA Site Collection.Project Server is enabled.

Migrate-SPProjectDatabase -DatabaseName "PWA_UAT" -SiteCollection ***http://PWA/PWA_UAT****

1

Did you create a Project Server Service Application and validate that a Project Server Service Instance is started on one or more SharePoint servers (if using defined MinRole (not Custom), after creating the PS SA, the instance should autostart on one or more servers).

  • Yes, Project Server Service Application is there and it is started. However its proxy is not there. Also I am not able to create the proxy. When I try, it shows error,'the topology service is not available in the farm'. When I dig more into the issue, I found that the server I am provided with is configured as 'Front-end role' and SharePoint 2016 is installed on it. And the earlier UAT server's role was 'Single-server far'. On which ll things were fine. – PallavN Jul 7 '18 at 11:26
  • So might be it i happening because of role. I don't know if there is different procedure to configure Project Server on server with 'Front-end role', as that on server with 'Single server farm' role. – PallavN Jul 7 '18 at 11:28
  • No, it won't make a difference. The Topology service is a core service. You'll want to check that the IIS App Pool for the topo service is running and that it exists (called "Application Discovery and Load Balancer Service Application" in Central admin). MinRole reference: docs.microsoft.com/en-us/SharePoint/administration/…. – Trevor Seward Jul 7 '18 at 21:27
  • Yes it exists and it is started. However proxy is not there for it as well. Likewise for most of the other Service Applications, including Project Server Service Application. – PallavN Jul 8 '18 at 11:28
  • It sounds like you either did not create the proxies using PowerShell, or the Config Wizard failed if that is the way you provisioned them. I would suggest in most cases just deleting the Service Applications and recreating them. You can do it through Central Admin -> Manage Service Apps. – Trevor Seward Jul 8 '18 at 18:32
0

This error got resolved. My server role was 'Front-end' server role.

  1. Site Collection not getting created. Error: Service Application not found.
  2. Service Application not found. Reason: Project Server Service Application Proxy is not there.
  3. Project Service Application Proxy not getting created. Error: The topology service is not available in the farm.
  4. The topology service is not available in the farm: Reason: "Application Discovery and Load Balancer Service" is disabled.
  5. ‘Front-end’ role doesn’t support this service, however ‘Application’ role does.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.