2

Recently ran into a major issue with a Sharepoint site which has effectively broken my ability to create a template of any sites on my site collection.

Normally I would template my current iteration by using

/_layouts/savetmpl.aspx

However this no longer working for me and i've no idea why. I've tried so many ways to try template any site but it's always the same error.

enter image description here

This message appears regardless of my attempts which include the following:

(all of these are saved with content) - Saving a current site as template - Saving a brand new site as a template - Saving a brand new site using older templates (a dozen in total going back 1 month) - Saving an old sub site as a template - Creating a subsite with the standard templates from Sharepoint and attempting to save as a template - Saving the templates on a different machine - Saving the templates on a different user account

I've done all the same options by saving them with no content as well, still the same result.

I've been implementing a few REST calls recently so that's the only thing thats really changed to my day to day work on the site so not sure if that has any bearing.

As always, any help or pointers are greatly appreciated as at this point i'm pretty desperate!

**I'm also waiting on MS sending my the ULS log file, taking their sweet time

0

Are the Publishing features enabled on the Site Collection. Save as Teamplate is not supported for Publishing sites.

  • Yes Mike publishing was enabled and was still able to template via the /_layouts/savetmpl.aspx However this is now defunct and i think my only route to continue creating new templates is via powershell – cod3r_jim Jun 29 '18 at 20:53
  • I should add to this that the /_layouts/savetmpl.aspx is once again working. There was some kind of outage across SharePoint in regards to using this template workaround for Publishing sites at the time I posted the question :) – cod3r_jim Aug 3 '18 at 9:31
0

Step 1: open site in SharePoint Designer Step 2: Site Option from ribbon. Step 3: Enable SaveSiteAsTemplate True.

OR

Powershell:

Connect-SPOService Set-SPOsite -DenyAddAndCustomizePages 0

  • Creating the template via Designer is grayed out despite it being set to true. It seems that MS have not completely removed the Save As Template workaround that many folk were using. Oh well. – cod3r_jim Jun 29 '18 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.