2

I have created a custom group-by view in a document library.

In the All Documents view, I can see all the documents I have added to the library, but when I switch to the custom view I am unable to see any of the documents (although, the number of documents in each group is correct!)

I have attached a screen grab of both views for reference.

Can anyone help me fix this please? When i created the view a week ago it worked fine, but then all of a sudden today it is not working.

Thanks in advance for any help provided!

enter image description here

enter image description here

1

It could be a field issue.

Try creating a simple text field and copying the Month/Year Calc value to it. Then try and group by the simple text field instead of Month/Year Calc. Does it allow you to see the grouped files underneath?

Workflow to copy values from Calculated field -> text field

If you don't want to have to manually copy across the values between the fields each time, you could consider making a Sharepoint Designer Workflow.

Use the SET command to set the text field value to the calculated field value. Configure the workflow to run automatically when the item is modified - the workflow will scan the two fields, if it sees that your calculated field and the text field don't match, it will copy across the value to make the text field match.

Open up the relevant site collection (e.g. departmental site). Select the List or Document Library you are working on, then select new workflow (as per the picture below):

enter image description here

Next choose a name for your new workflow - I use mainly 2010 workflows which are still compatible with the Sharepoint 2013 system.

Type "set" and select Set Field in Current Item

enter image description here

enter image description here

enter image description here

Next: configure the Start Options.

enter image description here

enter image description here

FINAL STEP - THEN SELECT SAVE AND PUBLISH WORKFLOW! (see top left of SP Designer menu)

Good luck with it

  • Hi Tally, thanks for the response. I tried what you suggested and it worked, so I'm guessing the issue is it cant group by on a calculated field? – Mikey Hill Jun 27 '18 at 8:50
  • Yes, certain types of fields can't be used for 'Group By', including the calculated field type (so it seems). I've experienced this issue with other field types previously - we have some add-in lookup fields which can be used cross-site and these can't be used in the Group By. – Tally Jun 27 '18 at 8:52
  • Aahh, ok. Thanks. Is there another way of achieving what I set out to achieve? I basically want to create a group by view of the document, which groups them by the Month/Year field, but where the format of the Date (and therefore grouping) is MMM-YY – Mikey Hill Jun 27 '18 at 8:55
  • I would recommend downloading Sharepoint Designer - it is free Microsoft software. A simple workflow will keep your two fields synchronised. You can use your text field to Group By instead. This will achieve what you need. If you get stuck I can post a picture so you can see what you need to do (I found SP Designer rather bewildering initially). Would you mind marking my Answer as accepted? (I do enjoy collecting the points!) – Tally Jun 27 '18 at 8:56
  • I do have SharePoint Designer, however I haven't had any experience setting up workflow with it so not entirely sure how to do what you have suggested – Mikey Hill Jun 27 '18 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.