1

I installed "SharePointPnPPowerShell2016" module sometime back when I was doing some research around PnP PowerShell.

Today I was trying to install "SharePointPnPPowerShellOnline" and got an error message which says commands are already installed. Because I already have "SharePointPnPPowerShell2016" module which comes with similar commands I could not install "SharePointPnPPowerShellOnline".

So in order to remove this module, I ran "Remove-Module" and got below error.

Remove-Module : No modules were removed. Verify that the specification of modules to remove is correct and those modules exist in the runspace. At line:1 char:1 + Remove-Module SharePointPnPPowerShell2016 + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ResourceUnavailable: (:) [Remove-Module], InvalidOperationException + FullyQualifiedErrorId : Modules_NoModulesRemoved,Microsoft.PowerShell.Commands.RemoveModuleCommand

When I was trying to see if a module is loaded or not I found out that "SharePointPnPPowerShell2016" is installed but not loaded.

See below screenshot for output for Get-Module and "Remove-Module" command.

enter image description here

  • how about running Uninstall-Module SharePointPnPPowerShell2016 and then installing the PnP PowerShell online ? – Gautam Sheth Jun 26 '18 at 5:14
  • @GautamSheth That worked. – Ravi Khambhati Jun 26 '18 at 19:28
  • cool, have posted that as answer ! Could you please accept it, so that it gets removed from the unanswered section, thanks !? – Gautam Sheth Jun 28 '18 at 8:30
2

As mentioned in the comments, you need to use the Uninstall-Module SharePointPnPPowerShell2016 to remove the PnP PowerShell 2016.

After that you can install the PnP SharePoint Online powershell using the executable file or using the Install-Module SharePointPnPPowerShellOnline command.

Download link - PnP PowerShell

1

I suggest you do not install the "SharePointPnPPowerShellOnline" and "SharePointPnPPowerShell2016" in the same server.

You could install in the different servers.

More reference:

SharePointPnP.PowerShell Commands.

And you could use “Uninstall-PnPAppInstance” command to remove the PNP PowerShell.

Uninstall-PnPAppInstance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.