0

We have MS Publisher 2016 documents in our SharePoint 2013 environment.

We used to be able to open theese files normally, edit, save and done.

Now the Files are only opening in read only mode and there is NO way to save the files. Every time we save the "Save As" option is the only one available.

A workaround that used to work until a few days ago was to open the "..." and choose edit file. This has now also stopped working.

Any suggestions?

0

Check whether you have disabled “Require check-out”.

Library settings > Versioning settings > In the Require Check Out section, under "Require documents to be checked out before they can be edited?", click No.

When check-out is required in the library, we can only open Publisher files in Read-Only mode as we cannot check it out in Publisher application.

Otherwise, you must check out the Publisher files firstly. After that, click Edit button to edit the Publisher files.

  • we have the check-in/out turned off in our environment by default. it is still possible for users to check out manually but nobody uses that for day to day work. – Cherubel Jun 27 '18 at 7:33
  • If the file is checked in, can you open it in Edit mode? – JoannaW_MSFT Jun 27 '18 at 8:39
  • nop. it always opens in protected. Other office programs also open in this way but they all have the Yellow ribbon where the "Edit" button is located. So you just press the edit button and then you are able to get along with your bizz. That yellow ribbon is misssing in the publisher documents. – Cherubel Jul 2 '18 at 6:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.