2

I have one sharepoint site on IIS 90 port and I want to map it to the DNS entry name TestSite. For this mapping IIS web site has to be binded to 80 port or else we have to use the url as http://TestSite:90.

Is there any way to map this DNS entry to web site in 90 port without binding it to 80 port.

closed as off-topic by wjervis, Gaurravs, Robert Lindgren, Dikesh Gandhi, moe Jun 27 '18 at 4:54

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Server questions not specific to SharePoint are off-topic here, but can be asked on ServerFault." – wjervis, Gaurravs, Robert Lindgren, Dikesh Gandhi, moe
If this question can be reworded to fit the rules in the help center, please edit the question.

3

DNS is not binding to a Port. You bind DNS to a IP <-> Name

You can have 2 different sites on 2 different ports without any issues.

So http://TestSite:90 and http://Testsite:80 will work perfectly fine.

As a general rule of thumb you should only bind one IP and Port combination to one webapplication at the same time (host header excluded - some additional steps need to be taken so the certificates are fine)

So in you need to assign no port when creating a new webapplication, since 80 is the default for non-https sites. You should not modify the bindings (in general) in IIS if you work with sharepoint. Just supply the port numbers needed when you create the webapplication.

Answer to the comments: Don't worry about the "load" on a port. The only load you need to worry about is the saturation of your network link and it wont make a difference on which port it communicates.

So taking this into account, you should, as the simplest solution, consider using a host header in order to make the second site available on port 80.

There is also a slightly more complex solution, in which you implement a web application proxy and publish the internal port 90 URL to port 80. But this is some added complexity I would not suggest based on your questions. If you do that you also need to ensure that your alternate access mappings are configured correctly.

So I would strongly suggest to use the host header approach.

  • Thanks for the reply.. But we dont want to use port number with host header so that the site at 90 port should be able access with the url (http:// Testsite). We want to achieve this without binding to 80 port. – user17274 Jun 24 '18 at 11:54
  • You can use host header with multiple sites on http port 80 (https is slightly more complex) Each site needs to have a unique host header and you should add a DNS A Record for each site in your DNS. main point is the host header needs to be unique. Both DNS records must point to the same IP. So you can have testsite and testsite2 – Heiko Hatzfeld_MSFT Jun 24 '18 at 14:25
  • As I mentioned in my previous comment we do not want to bind multiple sites to 80 port since this will increase load on 80 port. So we want to bind the site to 90 port with the url http:// testsite. Please let me know if there is any alternative solution to achieve this.. – user17274 Jun 25 '18 at 8:48
1

You cannot bind another port to a hostname. if you want to avoid having to use url:portnumber, you need to use port 80. There are only 2 standart ports for http-websites and that is 80 (http) and 443 (https). Browsers will always initiate the connection to these ports, depending on protocol, if no port-number was specified.

If you want to balance or redirect traffic, I would suggest to use a reverse proxy (nginx for example). Or you could have a simple page on port 80 that redirects all requests to another port. But that would be reflected in the address bar in the browser and linking to content on the page would also always require the port number.

DNS only maps name<->ip, not name<->socket.

0

100% agree to Heiko.

If a user enters http://testsite in his browser, it always uses port 80. This cannot be controlled by IIS or SharePoint without binding it on Port 80.

"Increased load on a port" -> A port itself doesn't really have a load-limitation.

Moving to port 90 will introduce trouble with Kerberos if enabled.

Not the answer you're looking for? Browse other questions tagged or ask your own question.