1

I have a list where a text column is created for people to enter ID numbers. These ID numbers are six digits long, and numbers-only (no letters, no symbols, etc). I noticed that people were entering in just about everything from partial numbers, letters, symbols, whatever. So, I tried to add validation, so that the entry HAD to be six digits long, and HAD to be number (number type instead of text).

Now I notice that since the field is six characters long, a comma is automatically placed in the number. We don't use commas, and I'd like to remove it.

I've seen other answers where a Calculated Column is used to get rid of the commas. But, is there a way within that same Calc Column that will enforce the other rules (numbers-only and six characters long) as well?

2

Your first option (text field) should work if you add the validation to the list. Try changing your column to Single line of text and add this validation formula to the list:

=IF(AND(LEN(YourColumnName)=6),(ISNUMBER([YourColumnName]+0)))
  • When used on a text field, this works as intended. Thanks! – DanJ Jun 27 '18 at 20:46
  • Using this formula still allows for the use of symbols. As long as there is at least 1 number in the text box it will allow you to save the item with the following symbols - . + £ $ – Kirito Oct 22 '18 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.