In SharePoint Online, we have a list with about 3500 entries in it. However there are 193 Columns on this list so it's quite big/wide.

Recently the 'Find an Item' box has started to return incorrect results. If I search for a value I know would return 10 entries I'll only get 4 returned. Initially I thought my view was the issue but I've created an 'all items' view and this still only returns 4 items, not the 10 I know are there.

I know they are there because I can do Ctr-F on the page and put the same search in and they are all there. This is not an acceptable workaround for the users.

I've requested a re-index of the list and waited 24 hours but the issue remains. I've checked list settings and there is no approval required for entries and any user with 'Read' can see content.

It feels like the amount of Columns is making the 'Find an Item' Box struggle but I can't find anything online to point me in the right direction.

Any help greatly appreciated.

  • Dan, were you able to resolve this? I am having a very similar issue, and I'm about to pull my hair out. My particular case involves a sharepoint list (custom app) that has worked fine for 3 years now!
    – BethVinson
    Aug 24, 2018 at 17:44
  • BethVinson - no, I was unable to resolve and ended up persuading the Users to use filters on the List Columns to find their results. They already think SharePoint is unfit for purpose and this has only strengthened that view. Hope you have a better outcome. If you do please let me know. Thanks and Good Luck - Dan
    – Dan
    Aug 29, 2018 at 10:38

1 Answer 1


Each column type has a size value listed in bytes. The sum of all columns in a SharePoint list cannot exceed 8,000 bytes. For more information please check the link

Regards, Balakrishnan

  • Balakrishnan, thanks for the info. The links are for SharePoint 2013. I assume they all still apply for SharePoint Online ?
    – Dan
    Jun 22, 2018 at 8:07
  • Greetings Dan, Yes it applies to SharePoint Online too. Jun 22, 2018 at 9:28
  • Balakrishnan, thanks for confirming. Current Status is the user has done some housekeeping on the list, removing 20 columns and moving older list items out of the list. I have requested a Re-Index of the list, which takes 24 hours, to see if the columns removed makes 'Find an Item' work any better. Dan
    – Dan
    Jun 25, 2018 at 12:53
  • Update :- Still not working. I worked out which items in the list were being returned and which were not. I then created a view of only 3 items, 2 that are returned when searched for, 1 that is not. From that view I searched for the term and only the 2 are returned. The view lists all columns and there is no obvious difference between the list items. I just can't figure out why 'Find an Item' is refusing to show all searched for items.
    – Dan
    Jun 27, 2018 at 8:20
  • Search uses index to return the results. can you please check if the column is indexed in the list? Jun 28, 2018 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.