Creating a SPD 2010 workflow. Trying to do something that I think should be simple.

Use a “Collect Data From a User” activity to collect 0 to many “people” that should be affiliated with a piece of content (Discussion).

After the assigned user completes the task, and after ensuring that there have actually been people associated from the task, I want to take the “people” from the Task list item and move them over to a field on the core Discussion item, that is also setup as a Person/Group field (allowing multiple).

I have tried using both the “Set Field in Current Item” and “Update List Item” activities to map the data over and in both cases tried using every combination of “Return field as” values to do the mapping (i.e. ‘String’, ‘Display Names, Semicolon Delimited’, ‘User Ids, Semicolon Delimited’, etc). In some cases I get vague errors about not being able to do mapping (I get it), in others, it sets the data, but only to the first user entered in the Task’s instance of the field.

After researching a bit, I find that the custom task from which I am pulling the data only contains one value, eventhough when I submitted the InfoPath form for the task, it accepted my data entry of two different users. So I think somewhere between the data entry into the custom tasks infopath form, and the update of the same data field in the Task list, the value is being lost.

I am sure this would be trivial with a custom activity, but we are exploring OOB ways of doing things and I have to imagine this is possible.

Am I missing something here? This seems “buggy”…

I am able to repro this in two different environments, using an out-of-box Discussion Board on an out-of-box Team Site.


  • Did you ever find an answer for this?
    – user7225
    Mar 5, 2012 at 22:41
  • Following up with Microsoft support services to see what the status of the KB is. Will post here when I find out more. I did get word that another issue will have a KB article released in the April 2012 CU timeframe.
    – Brian
    Mar 6, 2012 at 17:45
  • Has there been any solution to this. We are also facing the same problem and I am in a fix on how to solve this.
    – user37249
    Dec 25, 2014 at 9:53

2 Answers 2


Solution found!!

In case you want to update a MultiUser column in SPD 2010 you need to create a workflow variable of type String and set it to the following value:


The duplicate of users is not by mistake. The first one should be selected as [User Id Number] value and the second one as [Display Name]. This will result in pairs for each user to be inserted to the variable: [User1 Id];#[User1 display name];#[User2 Id];#[User2 display name] etc. And the separator of [;#] is not by mistake too.

In the end you'll come up with something like:

[%Current Item:Modified By%];#[%Current Item:Modified By%];#[%Current Item:Created By%];#[%Current Item:Created By%].

Afterwards use this variable as a value for the MultiUser field as [String], NOT as [User Ids, Semicolon delimited]. Otherwise it issues the

[Coercion Failed: Unable to transform the input lookup data into the requested type.]


Well, a couple of hours of fighting but it works!!

Good luck!


After opening a Support Ticket on this issue with Microsoft Support Services, I have received word that this is a known bug with SP 2010 & SPD2010. They are working to get a KB article published on it with some workarounds.

  • This bug still seems present when using SP2016 + SPD2013 + SharePoint 2010 Workflow.
    – ben
    May 17, 2018 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.