0

Whenever I open SharePoint Online Management Shell on windows 10 I get bellow error. Kindly help somebody to resolve it.

Please note, I am using windows 10 Version 1803(OS Build 17134.112) 64 bit and Management Shell 64 bit

Please help me.

enter image description here

My event log

enter image description here enter image description here

  • Are you running as Administrator? – jpollar Jun 18 '18 at 19:35
  • You don't need to run the shell as admin. – Trevor Seward Jun 18 '18 at 19:36
  • Yes, I am running as admin – Milind Jun 18 '18 at 19:36
1

I found solution for my issue, this error is thrown when you have script execution disabled on the system.

just run the command to unrestrict it and the error goes away.

Set-ExecutionPolicy RemoteSigned

Source :- https://technet.microsoft.com/en-us/library/ee176961.aspx

Hope it will help somebody.

0

It's tough to say what the root cause could be, but because you're seeing cert validation issues, it will likely come down to the computer clock is wrong, someone has removed the root cert from Windows which the shell leverages, or revocation checking on the system is disabled.

  • Than how can we solve it !! – Milind Jun 18 '18 at 19:37
  • I can't tell you exactly what the issue is with the provided information. Have you checked your computer clock to verify it has the correct time? You could always investigate the CAPI2 log in the Event Viewer to see what might be going on. You're going to have to put some effort into this to investigate. The information you're provided as-is is not enough to determine a root cause and solution. I gave you suggestions to look at to start with. – Trevor Seward Jun 18 '18 at 19:38
  • My computer time is absolutely correct and now I am checking event logs – Milind Jun 18 '18 at 19:39
  • I update original question with event log, log I could not understand at all :( – Milind Jun 18 '18 at 19:44
  • That does not look like the CAPI2 Event Log. Application Log isn't going to capture certificate errors like this. – Trevor Seward Jun 18 '18 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.