0

When saving my team site as template, it is a publishing site and has no 'save site as template' in site settings thus I saved the template using powershell scripts .

When creating a subsite with this custom template, it gives this error.

enter image description here

Because i don't use this feature for this site, i retracted/uninstalled and also removed it completely from my site collection but it still gives the same error except for the Problem part saying 'Not Installed'. I then tried using powershell to enable this feature on my team site but it says it can only be enabled on the top site collection which it is already enabled.

1

A site scoped feature is a site collection feature.

Try removing the custom features from the site prior to saving it as a site template. After removing the feature, save the site as a site template. Create a sub-site with the new site template, compare the results.

  • I tried uninstalling/removing the features then saving the team site as template, but it still produces the feature having problems 'Incorrect Template' error including 'Not Activated' . My current workaround that i found works is instead of saving the publishing site as template through powershell, i used powershell to enable 'SaveSiteAsTemplateEnabled' then access the save site url directly and save the site from there. For some reason using this method doesn't produce any errors and works fine – Kev F Jun 18 '18 at 3:48
  • If you want to find the cause, you could compare the issue site template file with the working file. – JoannaW_MSFT Jun 18 '18 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.