0

I am working on Creating a custom search result page with custom refiners. And I am stuck with choosing the appropriate crawled property to map to Refinable string managed property. Do someone knows the exact applicable crawled property for a 'Title' field from a document library.

I have already tried with OWS_Title, Title, OWS_LinkTitle. But no luck!

Edit1:

enter image description here

TIA

  • Have you run full crawl after you created new mapping? – Marek Sarad Jun 14 '18 at 9:36
  • I am on SP Online so I can not run a full crawl.. But I can wait till full crawl though – DvG Jun 14 '18 at 9:58
  • 1
    We only started moving to SP online so my experience in this area is still limited, but on prem the mappings only work after full crawl so most probably you need to wait. – Marek Sarad Jun 14 '18 at 10:04
1

Have you looked at the out of the box Title managed property? It is mapped to:

  • Title
  • MetadataExtractorTitle
  • TermTitle
  • Office:2
  • ows_BaseName
  • MailSubjec
  • Mail:5
  • People:PreferredName
  • Basic:displaytitle
  • ows_Title
  • Basic:10
  • Basic:9

I should point out that Title is generally a poor choice for refinement as the values are often unique. Refinement works best when a group of documents share that attribute.

  • Thanku for the reply, I actually need Title field as refiner because there is another field RecordNumber which is unique in my case..And these fields are from document library. So out of these list which one will suit for my case. ? – DvG Jun 15 '18 at 14:40
  • If it's the title field from a Document Library, use ows_Title. For RecordNumber use ows_RecordNumber. – Matthew McDermott Jun 15 '18 at 16:57
  • As per my question description, I have already used ows_title as crawled property.. and now i m awaiting for full crwal to happen. Then I can b confirmed.. FYI: i am on SP online – DvG Jun 15 '18 at 17:01
  • I have tried with TermTitle, MetadataExtractorTitle, Basic:displaytitle, Title, ows_Title, TermTitle, Title and ows_LinkTitle as refinable string001,2,3,4,5,6 but none of them worked even after full crawl.. Eventually, I ended up for doing Keyward search as Title: <search-keyward>. This has shown the relevant result – DvG Jun 22 '18 at 9:19
  • So, it's working for you? – Matthew McDermott Jun 23 '18 at 16:28
0

I have done a bit more research in that area and yes the crawl needs to happen. There seems to be a way (Haven't tested it) to force it by setting the property bag ("vti_searchversion") on sites. More info here: http://makingthings.work/trigger-a-full-crawl-on-sharepoint-online/

  • pls see my last comment on Matthew's answer – DvG Jun 22 '18 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.