2

Report Server Integration Feature has disappeared from Site Collection Features (Site - Site Settings - Site collection features under Site Collection Administration). Report Builder Report, Report Data Source and Report Builder Model are missing under New Document.

-Microsoft SQL Server 2012 RS Add-in for SharePoint is installed. -Service Connections is checked for the web application. -Service Application is Started

I'm not sure when the feature disappeared. Any known issues with recent security patch updates?

1

I had the same problem. I went to Add/Remove Programs, and saw that the Microsoft SQL Server 2012 RS Add-in for SharePoint had a recent date on it, indicating that it was recently patched. I was concerned about not running the right version of the rsSharePoint.msi installer so to ensure I was repairing with the current version, I right-clicked the item right in Add/Remove Programs and selected "Repair". It said "20 seconds remaining" for about 10 minutes, then finished with no confirmation. After that, all SSRS items are showing in the site again.

  • This just happened again and I should note that the same process worked, however, I had to close and re-open IE before I saw the menu options again. A page refresh would not work. – SomeGuy May 16 at 15:04
0

You can run rsSharePoint.msi and repair.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.