Hi we are using curl command line on our on-prem environment to download files but when we tried it in SharePoint Online it is no longer working. Is there any way or workaround on this one?

This is just only for the end user with contribute/read-only permission.

enter image description here


  • 1
    You can try using Powershell and PnP. c-sharpcorner.com/blogs/…. Official MS docs: docs.microsoft.com/en-us/powershell/module/sharepoint-pnp/…
    – Akhoy
    Jun 1 '18 at 10:05
  • Hi that is only possible for user with tenant access. We only need to enable it on normal users.
    – BizApps
    Jun 1 '18 at 10:25
  • Then, for a normal user, you can map the library to explorer view and directly copy from there. And I don't think you need to have tenant access permissions for using PnP. You only need to have permissions to the site and library to read.
    – Akhoy
    Jun 1 '18 at 10:33
  • Hi thanks im already checking out pnp. but i cant download the file
    – BizApps
    Jun 6 '18 at 4:01
  • Its Says File Not Found.
    – BizApps
    Jun 6 '18 at 5:10

CURL is no longer supported in SharePoint Online and I just tried using SharePoint Online PNP Pnp-GetFile using PowerShell and it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.