0

I created an InfoPath form with a module structure (set rules where depending on the option selected from a choice field a new module opens). Everything was fine until I published the form to a SharePoint list, now in the choice fields I see different options than the ones that are supposed to be there, options that are listed in other choice fields further down in the form, but not the ones that are supposed to be for the module selected. And when I go to the form to check it in edit mode, it is as it's supposed to be. Checked all rules as well, all is as it is supposed to be again. And it was working well until the time I published it to SharePoint, I tested it multiple times before publishing, all was correct. Any ideas where this is coming from and how to resolve it, as it is quite a big form and I don't want to be creating it again from the beginning? Thank you!

  • Seema like something weird is going on. Have you tried refreshing the fields in InfoPath Designer to see if everything still matches? I'd be curious to see if designer has accidentally created additional "duplicate" named columns on your list during the publishing process - maybe check your SP List to see if new columns were accidentally created by designer? – DRVR Jun 3 '18 at 9:27
  • Tried adding some new test entries, but again it is messed up for some reason and can't understand where this is coming from. All fields have been created as normal. – Benny Blanco Jun 4 '18 at 6:50
  • I'm debugging and fixing that issue now by re-creating the faulty choice fields and re-setting the rules. Couldn't find any other way to resolve that strange bug in the program. – Benny Blanco Jun 5 '18 at 7:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.