1

Here is the same scenario what I am facing. Sharepoint 2013 - SQL Server connection stopped working shortly after database server rename.

Note! :- in my case automatically Central admin is not accessible and I tried the powershell command mention in the above question got below error on SP power-shell.

enter image description here

On event viewer i am getting this below error which is occuring every 46th second. Event ID:-5586 Unknown SQL Exception -2146893007 occurred. Additional error information from SQL Server is included below.

A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: SSL Provider, error: 0 - The client and server cannot communicate, because they do not possess a common algorithm.)

Event 5586 (SharePoint Foundation) of severity 'Error' occurred 46 more time(s) and was suppressed in the event log

1

There was a mismatch of TLS protocols with SQL database server and Application server.

0

This Can be caused by different reasons and those might be

  • Insufficient SQL Server database permissions

  • SQL Server database is full

  • Incorrect MDAC version

  • SQL Server database not found

  • Incorrect version of SQL Server

  • SQL Server collation is not supported

  • Database is read-only

  • other fuctionality working fine, like sharepoint sites all are up and we have one more application server from which i can able to access Central admin as localhost (SharePoint farm is installed on one server A and we added some services to other server B to balance the load where no problem while connecting CA or SP PowerShell). so which of the above reason is a real issue. – Chetan Jun 5 '18 at 15:09
  • Have you changed any bindings? previously as you said you can access it through localhost – AIM4DREAM Jun 5 '18 at 15:33
  • from application server side we did not do any changes, But Database server was upgraded to recent patch to support TLS 1.1 and 1.2 versions . But our application server still uses TLS1.0 protocol . will that make any reason for this – Chetan Jun 6 '18 at 7:30
0

Possible Fix:

1.Open the SQL Server Configuration Manager (assuming you are using SQL 2008 or higher)

2.Browse down to SQL Server Network Configuration – Protocols for

3.Right-click “Named Pipes” in the right pane and choose Enable

4.You may need to restart the server for changes to take effect

Granting the farm database access account “VIEW SERVER STATE” under the SQL Server properties will also resolve this issue.

use [master]

GO

GRANT VIEW SERVER STATE TO [domain\timer_service_user]

GO

Also try this if its help full for you

https://docs.microsoft.com/en-us/previous-versions/office/sharepoint-2007-products-and-technologies/cc561042(v=office.12)

  • SQL Server Network Configuration is empty and do not have any protocols – Chetan Jun 7 '18 at 9:45
  • please check this option too. Are you able to connect sqlserver by SSMS(Sqlserver management studio)(if you installed). Please check several things. Window + Run , type SERVICES.MSC & enter. Now search all service of SqlServer in name column, it is in running mode, if not then run all except SqlServer Integrated Service (if you not using this feature). Go to Configuration Manager, there is sqlServerExpress. --go to sqlserver 2008 option , expand there is & enable first 3 only. – AIM4DREAM Jun 7 '18 at 14:04
  • I found the root cause. It was the problem with TLS protocols – Chetan Jun 7 '18 at 14:57
0

please check this option too.

Are you able to connect sqlserver by SSMS(Sqlserver management studio)(if you installed).

Please check several things.

Window + Run , type SERVICES.MSC & enter. Now search all service of SqlServer in name column, it is in running mode, if not then run all except SqlServer Integrated Service (if you not using this feature).

Go to Configuration Manager, there is sqlServerExpress.

--go to sqlserver 2008 option , expand there is & enable first 3 only.enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.