3

When I open my list on SharePoint, it always opens in quick edit mode, how can I fix this?

2
  • Can you share the URL of the site (endpoint might be helpful), also check options such whether the site is edit mode at page level or list leve. IF there are any check-outs, check-in the same and then try realoding the site list. Also try accessing the list using alternate routes such going to site collection and accessing the list (link) from there.
    – Arvind Raj
    May 31, 2018 at 2:35
  • The SharePoint designer solution did the fix. Thanks! Had 20 views to edit and designer was the easiest and fastest way. Jul 10, 2020 at 7:45

4 Answers 4

4

It seems that your default view is created using datasheet mode, try to create a view using standard template and then set it as default view.

It will no longer open in quick edit mode.

1
  • Not useful when you need to use datasheet mode (e.g. when you have a spreadsheet of data that needs to be added/turned into a list.
    – TylerH
    Nov 10, 2020 at 17:07
1

The simplest and most effective way is to edit the script in Sharepoint Designer. Simply change the "Type" (see the attached picture) from "GRID" to "HTML" and save changes. Voila! your list will open in View mode.

2
  • 1
    The SharePoint designer solution did the fix. Thanks! Had 20 views to edit and designer was the easiest and fastest way. Jul 10, 2020 at 7:45
  • Looks like this is actually referring to the "All Items" entry in the Views section of SP Designer. Editing the value as you suggest there does solve the problem.
    – TylerH
    Nov 10, 2020 at 17:12
-1

You can switch off quick edit on advanced settings page of the list.

quick edit switching off

UDP: Or you can change the view style on view's editing page.

enter image description here

2
  • The first option does not work; it still shows the 'quick edit' view, but doesn't show any of the options. Even worse, the "stop editing this list" option doesn't do anything.
    – TylerH
    Nov 10, 2020 at 16:59
  • I can't find the 'View Style' input list in your update, either.
    – TylerH
    Nov 10, 2020 at 17:03
-1

in your list default view is created using datasheet mode ,please create new view or you can use the existed view from library setting.

1
  • Not particularly useful if you need to create a list based on an existing spreadsheet of data (e.g. when you have lots of data already existing and just need to put it in a list).
    – TylerH
    Nov 10, 2020 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.