I have several libraries where I do not want to have Check in check out working. I went into Versioning settings and selected NO for required documents to check out before they can be edited and NO for require content approval for submitted items.

Even after doing the above config, if someone clicks on New to create a document in the library, once they save, SharePoint does not prompt for Metadata population at all, I have three mandatory choice columns and but the document gets checked out. The end users do not want that and I can't seem to figure why its not being disabled even after applying the config settings I mentioned above.

Also the site where libraries would reside, has sharepoint server publishing feature enabled. I also tried to make the columns non-mandatory but still it checks out the documents and please note that this appears only in a case if a file is dragged and dropped into a library or if someone clicks on New in the library. It works alright in case of upload.

In short, I just wanted to disable check in -check out completely and force users to populate the metadata if they click on New or drag a file in the library, if someone knows, please help.

1 Answer 1


If you have a required field and the field is not populated with a value, it will cause the document to be in a checked out state until it is filled in and subsequently checked in.

If this behavior is not desired, then you need to disable any required field.

  • thanks. i can't really make them non-mandatory because users will need to populate those columns without fail, so as per your theory I should set a default value if I want to keep a column required, right? Currently none of the required columns are set to any default value.
    – mdevm
    May 29, 2018 at 19:35
  • I think that should work -- or user retraining.
    – user6024
    May 29, 2018 at 19:35
  • I made the mandatory columns set to a default value, but it still checks out the document if someone Clicks on New or does drag n drop. Any solution?
    – mdevm
    May 29, 2018 at 19:50
  • You may be able to set up a template (assuming you only need one) with the default values, but if that doesn't work, you're out of luck unless you make the columns non-mandatory.
    – user6024
    May 29, 2018 at 19:53
  • I had to make em non-mandatory and set them all to default values, there was actually one more column i did not touch. But this is not good at all, I will have to raise this in a Microsoft forum.
    – mdevm
    May 29, 2018 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.