When using the RSS viewer web part under classic authentication to get the web part to work through a proxy you would add the following to the web.config file.

    <defaultProxy enabled="true" useDefaultCredentials="true">  
        <proxy bypassonlocal="true" proxyaddress="http://PROXY IP:8080" />

As long as the account that is used to run the application pool that the Web Application is in has access through the proxy it should work.

In Claims Based authentication it does not. What would I need to change to try and get this working. The error message I am getting can be seen below:

ProtocolError occured trying to complete the request. The server returned a status code of : ProxyAuthenticationRequired and the status description is : "Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied. )"

1 Answer 1


I tried the same but ended up creating a seperate, Windows authenticated extension for my site on a different port. That one you can use with the apppool identity without any problems. Same goes for using REST for instance; couldn't get that to work via claims either. Setting up an extended site for these purposes seems to be the easiest route (and there's nothing much wrong with it either).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.