1

I have a batch job in an APP server in a SharePoint Production farm that executes Fast Search queries. Basically, the batch job calls the Search web service to execute search queries.

Previously, when I run this batch job in the APP server, it's able to complete without errors.

Now, when I run the batch job in the APP server, it's throwing me the error:

The search request was unable to execute on FAST Search Server.. 
Stack Trace:    
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

However, when I run the batch job in the WFE server, it's able to complete without errors.

More details are: * Search Topology: 3 crawl components; 1 is at the FAST search server and the other 2 are at 2 WFE servers. 1 admin component at the FAST Search server. 1 query component at the FAST Search server. * Version: SharePoint 2010

Would greatly appreciate any ideas and suggestions on how to troubleshoot this issue!

  • Which server(s) are running the QR component of FAST? – Mikael Svenson May 25 '18 at 13:27
  • Thanks for replying, Mikael! It's the FAST server itself that has the query component. – Celbester May 31 '18 at 5:26
  • Could be a dns issue perhaps? And how are you searching? Sample code/script would help. Thing is search will hit the proxy on the wfe before going to QR component (if my mind serves me correct). There's a diagram in my book I know, but out enjoying the sun atm :) – Mikael Svenson May 31 '18 at 17:15
  • Thanks for the suggestion, Mikael! After testing, the culprit is setting a really high row limit instead of retrieving results in a paged manner. :) – Celbester Jun 8 '18 at 10:31
0

After testing, I saw that there is no issue if the search query's row limit is smaller (example: 100). However, when I set my row limit to a really large number (example: 1 million because my intention was to get the total result count), that's when the error occurs. So I'll need to revise the code to retrieve results in a paged manner. Hope this helps someone. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.