0

I have a textbox in a form from Infopath 2013, which is set to a "single line of text".

But when a form is uploaded to a Sharepoint form-library, the column is changed to "Multiple lines of text", which makes the column unfilterable (not sure if that's a word).

Does anyone have a solution to this?

Any help would be greatly appriciated.

0

Open the form in the InfoPath Designer, right click the text box and click “Text Box Properties”.

In the Display tab, make sure the Multi-line checkbox is unticked.

enter image description here

  • I've already made sure that box is unchecked. I have no idea where else I could change this setting. – A. Toftegaard May 28 '18 at 9:17
0

I'm not sure it is possible to downgrade the amount of memory allocated to a column. I would make a new column of single line of text, then use the "Quick Edit" mode to copy the one column to the next.
If you need the column name to stay the same, delete the old multiline and recreate it with the same name and recopy your data back and finally remove your interim column.

This could also be done by powershell if you wanted, or create a workflow that moves the data and then trigger it with Information Management Policy. It just depends on your level of access and expertise.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.