1

I have 2 servers in my farm (plus, an additional separate DB Server). I use one of the servers as a Central Admin server and the other is a combination WFE and App Server. The search application is on the App Server. The Central Admin server is on a separate but internal network. SharePoint is used within my organization as an intranet.

When I navigate to the Search Administration page on the Central Admin server the "System Status|Administration status" shows the message: "The underlying connection was closed: An unexpected error occurred on a send." The "Search Application Topology" section shows the app servers name with green checks for every component: Admin, Crawler, Content Processing,....

Clicking on the "Crawl Log" link on the left shows the "Sorry, something went wrong" (SSWW) page with the message "An existing connection was forcibly closed by the remote host". In the logs on the Central Admin server, shows the error appearing when a call is made to the HTTPS address of the Search's web service on the App Server. On the Central Admin server, I open IE and plug in the URL for the web service. I receive a message "There is a problem with this website's security certificate."

Just for fun, I change the URL. Rather than use the HTTPS binding, I try the HTTP site's connection, and I receive no error, just information about the SearchAdminWebServiceApplication Service. So the HTTP binding appears to be operational.

So, I have 2 questions:

How do I repair the HTTPS SharePoint Web Service binding (which appears like a certificate issue) to make HTTPS work correctly?

-OR-

How do I shut HTTPS binding off and tell SharePoint to only use the HTTP binding? Is it as simple as removing the binding for the site?

If you need more information or if this is not clear please let me know and I'll do my best to make it more understandable.

Thanks for reading and thank you in advance.

Matt

0

Run the below command to provision the Web services which restored all the common Web service settings

$Service=Get-SPServiceHostConfig

$Service.Provision()

Access the Search Service Application, check whether the error "Sorry something went wrong : An existing connection was forcibly closed by the remote host" is resolved.

  • I tried re-provisioning the web service on both servers to no luck. Wondering if it could be a firewall issue since the servers are on a different network? Would I observe these issues if ports 32843 and 32844 are being blocked between the 2 servers? CA is not where Search Services are installed, which explains why search would be working but the status of search is not observable from the CA server. – Matt May 21 '18 at 12:45
  • Hi, did you ever get this resolved? We have a similar issue. – j.strugnell Sep 14 '18 at 14:31
  • I'm sorry...I just checked back to this post because it's been awhile and I hadn't heard anything and I saw your question. yes - i was able to solve this issue. I'll be posting – Matt Oct 12 '18 at 19:33
0
  • If you browse a SharePoint Web-Service, it is absolutely OK to receive a certificate error. WebServices use the SharePoint internal certificate. This certificate is configured in a wired way, so you cannot see it in IIS-Bindings.. IIS says SSL certificate: not selected. You should ensure this wasn't misconfigured during troubleshooting.
  • In a SharePoint farm, a lot of ports must be opened between servers to allow smooth communication. I bring your farm-design into question: Why do you host a separate SharePoint-Server only to host CentralAdministration (quote: "the other is a combination WFE and App Server")? If this is really true, i recommend to move CA to the other server and remove the second one completely.
  • I'd love to have a single server that contains CA, WFE and the App server. The regulations I must follow dictate a separate CA. – Matt May 25 '18 at 14:07
0

Eventually, I was able to find a solution to the issue I encountered.

I was able to discover a post that mentioned TLS. We had just made modifications to TLS, disabling TLS 1.0 and only enabling TLS 1.1 and 1.2. I looked on one of the servers and discovered that TLS 1.0 was disabled - the other server did not have TLS 1.0 disabled.

I enabled TLS 1.0 on the server where it was disabled, restarted the machine and I didn't have the error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.